dev-python/jaraco-stream: add Python 3.7, more verbose tests
authorLouis Sautier <sbraz@gentoo.org>
Wed, 25 Jul 2018 21:20:46 +0000 (23:20 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 25 Jul 2018 21:20:46 +0000 (23:20 +0200)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-python/jaraco-stream/jaraco-stream-1.2.ebuild

index 8aa4e6c40820d529120286fe6c9365dd126478c6..b990da9621d02981929c6c7ad1a9625e52dd790d 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
 
 inherit distutils-r1
 
@@ -47,7 +47,7 @@ python_compile_all() {
 python_test() {
        # Skip one test which requires network access
        # Override pytest options to skip flake8
-       PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
+       PYTHONPATH=. pytest -vv --ignore=jaraco/stream/test_gzip.py \
                --override-ini="addopts=--doctest-modules" \
                || die "tests failed with ${EPYTHON}"
 }