old
authorMike Frysinger <vapier@gentoo.org>
Fri, 6 Apr 2007 21:18:14 +0000 (21:18 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 6 Apr 2007 21:18:14 +0000 (21:18 +0000)
app-editors/nano/files/digest-nano-2.0.2 [deleted file]
app-editors/nano/nano-2.0.2.ebuild [deleted file]

diff --git a/app-editors/nano/files/digest-nano-2.0.2 b/app-editors/nano/files/digest-nano-2.0.2
deleted file mode 100644 (file)
index 0ac40ce..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 38046476096530e19a7e805513c64108 nano-2.0.2.tar.gz 1302412
-RMD160 56355e7ef646cbb924ca84985798ed4746b9758c nano-2.0.2.tar.gz 1302412
-SHA256 884af214d4b4bf2cb064806070e746eb0f8302e7942324496f5bb93a9a06af90 nano-2.0.2.tar.gz 1302412
diff --git a/app-editors/nano/nano-2.0.2.ebuild b/app-editors/nano/nano-2.0.2.ebuild
deleted file mode 100644 (file)
index 132811a..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.2.ebuild,v 1.12 2007/02/28 21:56:14 genstef Exp $
-
-#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
-#ECVS_MODULE="nano"
-#ECVS_AUTH="pserver"
-#ECVS_USER="anonymous"
-#inherit cvs
-
-MY_P=${PN}-${PV/_}
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
-       nls? ( sys-devel/gettext )
-       !ncurses? ( slang? ( sys-libs/slang ) )"
-PROVIDE="virtual/editor"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       if [[ ! -e configure ]] ; then
-               ./autogen.sh || die "autogen failed"
-       fi
-}
-
-src_compile() {
-       local myconf=""
-       use ncurses \
-               && myconf="--without-slang" \
-               || myconf="${myconf} $(use_with slang)"
-
-       econf \
-               --bindir=/bin \
-               --enable-color \
-               --enable-multibuffer \
-               --enable-nanorc \
-               --disable-wrapping-as-root \
-               $(use_enable spell) \
-               $(use_enable justify) \
-               $(use_enable debug) \
-               $(use_enable nls) \
-               $(use_enable unicode utf8) \
-               $(use_enable minimal tiny) \
-               ${myconf} \
-               || die "configure failed"
-       emake || die
-}
-
-src_install() {
-       emake DESTDIR="${D}" install || die
-
-       dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
-       dohtml *.html
-       insinto /etc
-       newins doc/nanorc.sample nanorc
-
-       insinto /usr/share/nano
-       doins "${FILESDIR}"/*.nanorc || die
-       echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
-
-       dodir /usr/bin
-       dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
-       elog "More helpful info about nano, visit the GDP page:"
-       elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}