sys-fs/zerofree: Version bump, replace sed delimiter
authorJoshua Kinard <kumba@gentoo.org>
Thu, 27 Feb 2020 03:22:00 +0000 (22:22 -0500)
committerJoshua Kinard <kumba@gentoo.org>
Thu, 27 Feb 2020 03:22:00 +0000 (22:22 -0500)
- Add ebuild for zerofree-1.1.1
- Replace colon sed delimiter w/ pipe to resolve #710818
- Bump to EAPI 7
- Remove useless src_compile and use the built-in default

Signed-off-by: Joshua Kinard <kumba@gentoo.org>
Package-Manager: Portage-2.3.89, Repoman-2.3.20

sys-fs/zerofree/Manifest
sys-fs/zerofree/zerofree-1.0.4.ebuild
sys-fs/zerofree/zerofree-1.1.1.ebuild [new file with mode: 0644]

index df3f07d3c3deb8446dca7ad4f6d1624209360f52..7c5efcfddaa577bb337057b1d7496f876b3a0678 100644 (file)
@@ -1 +1,2 @@
 DIST zerofree-1.0.4.tgz 8509 BLAKE2B d2d5872ad22e7c5f08e00083b0dadb5411023df9d129ec3bd08637e8a74f77f13a535e6f2c1a7cd4d390ed7a0d0b6e2433dacfa89336bb16ffb64c0d1c409929 SHA512 8172c8c43794eab1f751a700f847098343659ceabaf6ab78c3c902b34cf9b0db0dda75308b6bc80d22afccd11be25f35070ca6d715c3282c5c7c7106f598b42b
+DIST zerofree-1.1.1.tgz 8710 BLAKE2B 76a84de7db60473c8824129a29515212acc74235e2139eb15fe7f41d1801c42c85378734fdf39a668f0a4eb285c55c49ce2281dda9444b2008557897428bc645 SHA512 2d7ee57a877bff2491c48054338a26d624ae75c238ac2b0568a75de88b6621c16cc1e7d65500879825d14d8ba44a5173587a061459072769c165bee47c3f9f1c
index dfa8789278408add65ccbbb32d70d92e6bd330d2..6e360c833a1845ecb1337c9684fd6e9380bac3f5 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=7
 inherit eutils toolchain-funcs
 
-DESCRIPTION="Zero's out all free space on a filesystem"
+DESCRIPTION="Zeroes out all free space on a filesystem"
 HOMEPAGE="http://frippery.org/uml/index.html"
 SRC_URI="http://frippery.org/uml/${P}.tgz"
 
@@ -18,16 +18,14 @@ RDEPEND="${DEPEND}"
 
 src_prepare() {
        # Honor system CFLAGS.
+       # Use pipes for the sed delimiter to resolve #710818.
        sed -i \
-               -e "s:CC=gcc:CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}:g" \
-               -e "s:-o zerofree:\$(CFLAGS) \$(LDFLAGS) -o zerofree:g" \
-               -e "/-lext2fs/{ s:-lext2fs::g; s:$: -lext2fs:g; }" \
+               -e "s|CC=gcc|CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}|g" \
+               -e "s|-o zerofree|\$(CFLAGS) \$(LDFLAGS) -o zerofree|g" \
+               -e "/-lext2fs/{ s|-lext2fs||g; s|$| -lext2fs|g; }" \
                Makefile || die "Failed to sed the Makefile"
-}
 
-src_compile() {
-       # Just a Makefile, nothing fancy.
-       make || die "Failed to compile ${PN}."
+       eapply_user
 }
 
 src_install() {
diff --git a/sys-fs/zerofree/zerofree-1.1.1.ebuild b/sys-fs/zerofree/zerofree-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..6e360c8
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Zeroes out all free space on a filesystem"
+HOMEPAGE="http://frippery.org/uml/index.html"
+SRC_URI="http://frippery.org/uml/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+DEPEND="sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       # Honor system CFLAGS.
+       # Use pipes for the sed delimiter to resolve #710818.
+       sed -i \
+               -e "s|CC=gcc|CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}|g" \
+               -e "s|-o zerofree|\$(CFLAGS) \$(LDFLAGS) -o zerofree|g" \
+               -e "/-lext2fs/{ s|-lext2fs||g; s|$| -lext2fs|g; }" \
+               Makefile || die "Failed to sed the Makefile"
+
+       eapply_user
+}
+
+src_install() {
+       # Install into /sbin
+       into /
+       dosbin zerofree
+}