net-proxy/haproxy: Add support for DeviceAtlas API
authorBertrand Jacquin <bertrand@jacquin.bzh>
Wed, 5 Oct 2016 23:52:00 +0000 (00:52 +0100)
committerRobin H. Johnson <robbat2@gentoo.org>
Sun, 22 Jan 2017 20:59:39 +0000 (12:59 -0800)
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=564160
Fixes: https://github.com/gentoo/gentoo/pull/2487
Package-Manager: portage-2.3.0
(cherry picked from commit e25fbc24754115cdceb72ae450932f2ed55df8f4)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
net-proxy/haproxy/haproxy-1.6.10-r1.ebuild
net-proxy/haproxy/haproxy-1.6.9999.ebuild
net-proxy/haproxy/haproxy-1.7.0.ebuild
net-proxy/haproxy/haproxy-1.7.9999.ebuild
net-proxy/haproxy/metadata.xml

index df81d1e500a95d615bc559e0b192440b527f7c26..be577151a05025a8efce20a3a82ad68ee6efe903 100644 (file)
@@ -23,6 +23,7 @@ LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
 REQUIRED_USE="pcre-jit? ( pcre )
+       device-atlas? ( pcre )
        ?? ( slz zlib )"
 
 DEPEND="
index df81d1e500a95d615bc559e0b192440b527f7c26..be577151a05025a8efce20a3a82ad68ee6efe903 100644 (file)
@@ -23,6 +23,7 @@ LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
 REQUIRED_USE="pcre-jit? ( pcre )
+       device-atlas? ( pcre )
        ?? ( slz zlib )"
 
 DEPEND="
index df81d1e500a95d615bc559e0b192440b527f7c26..be577151a05025a8efce20a3a82ad68ee6efe903 100644 (file)
@@ -23,6 +23,7 @@ LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
 REQUIRED_USE="pcre-jit? ( pcre )
+       device-atlas? ( pcre )
        ?? ( slz zlib )"
 
 DEPEND="
index df81d1e500a95d615bc559e0b192440b527f7c26..be577151a05025a8efce20a3a82ad68ee6efe903 100644 (file)
@@ -23,6 +23,7 @@ LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
 REQUIRED_USE="pcre-jit? ( pcre )
+       device-atlas? ( pcre )
        ?? ( slz zlib )"
 
 DEPEND="
index fe6d5f4f39e8dcb907282bd4109e4fe6ea7e6256..ddb31ac2bb8b2fda940cb0daef661f14a6fd1720 100644 (file)
@@ -23,7 +23,7 @@ Its event-driven architecture allows it to easily handle thousands of simultaneo
                <flag name="pcre-jit">Use JIT support for PCRE</flag>
                <flag name="slz">Use <pkg>dev-libs/libslz</pkg> compression library</flag>
                <flag name="tools">Install additional tools (halog, iprange)</flag>
-               <flag name="device-atlas">Device Detection using Device Atlas</flag>
+               <flag name="device-atlas">Use <pkg>dev-libs/device-atlas-api-c</pkg> library</flag>
                <flag name="51degrees">Device Detection using 51 Degrees</flag>
                <flag name="wurfl">Device Detection using WURFL</flag>
        </use>