sys-libs/glibc: avoid RESTRICT=strip and use 'dostrip -x /'
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 18 Oct 2019 06:46:54 +0000 (07:46 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 18 Oct 2019 06:47:16 +0000 (07:47 +0100)
RESTRICT=strip + 'dostrip /' does not have a desired effect
of enabling (possibly selective) stripping in portage:
https://bugs.gentoo.org/697960

Workaround it by using 'if foo && dostrip -x /' instead of
RESTRICT=strip + 'if foo || dostrip /'.

Reported-by: Arfrever Frehtes Taifersar Arahesis
Fixed-by: Arfrever Frehtes Taifersar Arahesis
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-9999.ebuild

index d1ad8e513fbb271fe3f802108be85f169c16419f..08a4eba83b3ea230d62ac905084c9f721c891f05 100644 (file)
@@ -80,7 +80,6 @@ fi
 #   losing it's '.symtab' entries.
 # As Gentoo's strip does not allow us to pass less aggressive stripping
 # options and does not check the machine target we strip selectively.
-RESTRICT=strip
 
 # We need a new-enough binutils/gcc to match upstream baseline.
 # Also we need to make sure our binutils/gcc supports TLS,
@@ -1204,7 +1203,7 @@ glibc_do_src_install() {
 
        # Avoid stripping binaries not targeted by ${CHOST}. Or else
        # ${CHOST}-strip would break binaries build for ${CTARGET}.
-       is_crosscompile || dostrip /
+       is_crosscompile && dostrip -x /
        # gdb thread introspection relies on local libpthreas symbols. stripping breaks it
        # See Note [Disable automatic stripping]
        dostrip -x $(alt_libdir)/libpthread-${upstream_pv}.so