Version bump lxml to 2.3.1.
authorDirkjan Ochtman <djc@gentoo.org>
Tue, 11 Oct 2011 15:07:58 +0000 (15:07 +0000)
committerDirkjan Ochtman <djc@gentoo.org>
Tue, 11 Oct 2011 15:07:58 +0000 (15:07 +0000)
Package-Manager: portage-2.1.10.24/cvs/Linux x86_64

dev-python/lxml/ChangeLog
dev-python/lxml/Manifest
dev-python/lxml/lxml-2.3.1.ebuild [new file with mode: 0644]

index b90933dfab967d7be12ecbb167d26fb7f0c84885..00ee0a4a286ab02f15f742cc418d09fe7d1f9cad 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/lxml
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.104 2011/09/19 21:52:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.105 2011/10/11 15:07:58 djc Exp $
+
+*lxml-2.3.1 (11 Oct 2011)
+
+  11 Oct 2011; Dirkjan Ochtman <djc@gentoo.org> +lxml-2.3.1.ebuild:
+  Version bump to 2.3.1.
 
   19 Sep 2011; Markus Meier <maekke@gentoo.org> lxml-2.3.ebuild:
   add ~arm, bug #383195
index 698c8685feea46273e9eaa197db5d233cdecce77..b16ac27bfdf84f5e787061703eab06e78aecebac 100644 (file)
@@ -1,14 +1,16 @@
 -----BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
+Hash: SHA512
 
+DIST lxml-2.3.1.tgz 3131805 RMD160 d4c92d582aa4f2615fd1cf30a9a33d09d5539119 SHA1 20a8732a35cc324795eaa57c754741c509825923 SHA256 d5fc97bc9f4d0d0c8a73dcfcfb6fb2fe20d4da673e426ed594670a83e1485dc5
 DIST lxml-2.3.tgz 3187747 RMD160 fb74261101027506a480729dfd5ef303c29d14d5 SHA1 2384caa37b94b312d97d3e4b773aeccca94f9c76 SHA256 eea1b8d29532739c1383cb4794c5eacd6176f0972b59e8d29348335b87ff2e66
+EBUILD lxml-2.3.1.ebuild 2317 RMD160 5a85e0dfe86509ae71a5971e7a96de8b09163de9 SHA1 806fc7ea350fe7cd0c62e850ddd86a42ce8dc6ba SHA256 fa80274c5818b2fa1848516d3d723e4cfe64bd10929cbc6e15cf4f73738ebe6a
 EBUILD lxml-2.3.ebuild 2312 RMD160 69f0c92207b9ff9858f80bd2ad203c81592c9261 SHA1 55530ebf54a595c303708d3ee218fa796f26eb1a SHA256 bc113343f68ebacdf8afd170adacbf297638820582c653eaf87f5a68b7f17e88
-MISC ChangeLog 12831 RMD160 ba53d98c35259296f439d778d81e6b4b80fddb55 SHA1 3ad6bd8323312b95950c151240dc4037465f5ac7 SHA256 8c1c23a3e724ac1a33ecc682a937f586f7be519fde67839e6d4deea9bc1fe17b
+MISC ChangeLog 12949 RMD160 d08d4b3700a866ae8417209c96f8b403aaa0cfe5 SHA1 fadc2431bcac2061d0db647e1cb4ae93dcf1c641 SHA256 af85aabf4a4b08751ae0a18cebcaa3ebc93ee97dc9c00ea48b21885438e46da0
 MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
 -----BEGIN PGP SIGNATURE-----
 Version: GnuPG v2.0.17 (GNU/Linux)
 
-iEYEARECAAYFAk53ucIACgkQkKaRLQcq0GJ6mwCferAqr9P7kaLI5LOkYVCfVeVt
-OjEAoICCIfn6a3khNVzibTyr9wfsuSq3
-=4yAp
+iEYEAREKAAYFAk6UW9kACgkQxeMuLWsGW/uvdACfYQL8J+Q2/Uxo7o19KyCogNhI
+bCMAnRAyAO8Px2HLssSNznj3q2/PSSvu
+=zlNq
 -----END PGP SIGNATURE-----
diff --git a/dev-python/lxml/lxml-2.3.1.ebuild b/dev-python/lxml/lxml-2.3.1.ebuild
new file mode 100644 (file)
index 0000000..afa41e0
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-2.3.1.ebuild,v 1.1 2011/10/11 15:07:58 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+MY_P="${PN}-${PV/_/}"
+
+DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
+HOMEPAGE="http://codespeak.net/lxml/ http://pypi.python.org/pypi/lxml"
+SRC_URI="http://codespeak.net/lxml/${MY_P}.tgz"
+# SRC_URI="http://codespeak.net/lxml/dev/${MY_P}.tgz"
+
+LICENSE="BSD ElementTree GPL-2 PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples +threads"
+
+RDEPEND=">=dev-libs/libxml2-2.7.2
+       >=dev-libs/libxslt-1.1.15
+       >=dev-python/beautifulsoup-3.0.8"
+DEPEND="${RDEPEND}
+       dev-python/setuptools"
+# lxml tarball contains files pregenerated by Cython.
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+# Compiler warnings are suppressed without --warnings option.
+DISTUTILS_GLOBAL_OPTIONS=("--warnings")
+
+src_compile() {
+       distutils_src_compile $(use threads || echo --without-threading)
+}
+
+src_test() {
+       testing() {
+               # Tests broken with Python 3.
+               [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+               local module
+               for module in lxml/etree lxml/objectify; do
+                       ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}.so" "src/${module}.so" || die "ln -fs src/${module} failed"
+               done
+
+               local exit_status="0" test
+               for test in test.py selftest.py selftest2.py; do
+                       einfo "Running ${test}"
+                       if ! PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" "${test}"; then
+                               eerror "${test} failed with $(python_get_implementation) $(python_get_version)"
+                               exit_status="1"
+                       fi
+               done
+
+               return "${exit_status}"
+       }
+       python_execute_function testing
+}
+
+src_install() {
+       distutils_src_install
+
+       if use doc; then
+               dohtml -r doc/html/* || die "Installation of documentation failed"
+               dodoc *.txt || die "Installation of documentation failed"
+               docinto doc
+               dodoc doc/*.txt || die "Installation of documentation failed"
+       fi
+
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins -r samples/* || die "Installation of examples failed"
+       fi
+}