sys-libs/openipmi: Bump to version 2.0.28
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 7 May 2020 13:57:52 +0000 (15:57 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 7 May 2020 14:06:54 +0000 (16:06 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/openipmi/Manifest
sys-libs/openipmi/openipmi-2.0.28.ebuild [new file with mode: 0644]

index f44898e3335640150a49fa3d8bce8a466b032543..756f5ec04fbf5dce821a342293be239c3948f8d1 100644 (file)
@@ -1,3 +1,4 @@
 DIST OpenIPMI-2.0.22.tar.gz 3081893 BLAKE2B 6ec5ec7f61f3033a9d953df4b091522fa5bd891a93dfe648f807548e3dc0f5ffc0d15af9b687379e6749d7b97ee2fd6c7f9e713aaa7423b82bf099fb2d0fb6b8 SHA512 78017fc0b52ce6a83db45f595f50170410120c9f7394429869c177ee40ea5b924bcc0e36bb60f9368a75a2f78ff71c70ae3631ba55a207cfb6eb4f62aa44ff89
 DIST OpenIPMI-2.0.26.tar.gz 3124706 BLAKE2B 08afeae1063b404dec3d6f9e5decdf9ac516c0096d8db3c42ff275c280267aa6a202cf4c63c5044cf1d24a95ecd617ad36c15e5c98c6b9cdad2647227f649ae6 SHA512 ffd1ea60727973238461c95373c71e28da04e2fd163bfcb8f5ef9a8ac197b554773231c064cac71c64fc7ccd720085a781fe3c6c8ed3c9dc5cc8ca88fff6f2d0
 DIST OpenIPMI-2.0.27.tar.gz 3125193 BLAKE2B 86639a86803e49393aefbaf5b1d1fee8e2bf399b2772bdee7d07a00d5e6657efe5cdf962cacb0397f9de5deb0b18edc05783c3388f4fc19e1ee2de4c01be0663 SHA512 44aa2eb97559514d61654434f24bf8e87c3f89ea7095fd3d46c1a889e16c128f29ca19cfb9747afc7fd432ada84406ee884bc8b9c65e28b8bd033d368b744fe3
+DIST OpenIPMI-2.0.28.tar.gz 3118911 BLAKE2B 0f4192dc536ec1767ee72cf9f0d2c3b021e5f8e88b4029846a27c3b6561a3c63d44f4bad7ced234a171504804d2d9cdd90d0c6a6dc178f9f76ea52f6df20b9d0 SHA512 faaca335f7ff582f396d588c6b3736b4e2756a9914becba75550878a10d7acce55e85912bcf5cd9e482c3e646eb472a8a055c520f2dcba7a874f0c0f120502da
diff --git a/sys-libs/openipmi/openipmi-2.0.28.ebuild b/sys-libs/openipmi/openipmi-2.0.28.ebuild
new file mode 100644 (file)
index 0000000..f703303
--- /dev/null
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="https://sourceforge.net/projects/openipmi/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV/_/-}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86"
+IUSE="crypt snmp perl python static-libs tcl"
+S="${WORKDIR}/${MY_P}"
+RESTRICT='test'
+
+RDEPEND="
+       dev-libs/glib:2
+       sys-libs/gdbm:=
+       sys-libs/ncurses:0=
+       sys-libs/readline:0=
+       crypt? ( dev-libs/openssl:0= )
+       snmp? ( net-analyzer/net-snmp )
+       perl? ( dev-lang/perl:= )
+       python? ( ${PYTHON_DEPS} )
+       tcl? ( dev-lang/tcl:0= )"
+DEPEND="${RDEPEND}
+       >=dev-lang/swig-1.3.21"
+BDEPEND="virtual/pkgconfig"
+
+# Gui is broken!
+#              python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.0.26-tinfo.patch" #501510
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # Bug #298250: parallel install fix.
+       sed -r -i \
+               -e '/^install-data-local:/s,$, install-exec-am,g' \
+               cmdlang/Makefile.{am,in} || die
+
+       # We touch the .in and .am above because if we use the below, the Perl stuff
+       # is very fragile, and often fails to link.
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               # these binaries are for root!
+               --bindir="${EPREFIX}"/usr/sbin
+               --with-glib
+               --with-glibver=2.0
+               --with-swig
+               --without-tkinter
+               $(use_with snmp ucdsnmp yes)
+               $(use_with crypt openssl yes)
+               $(use_with perl perl yes)
+               $(use_with tcl tcl yes)
+               $(use_with python python yes)
+       )
+
+       # GUI is broken
+       #use tk && use python && use !tcl && \
+       #       ewarn "Not building Tk GUI because it needs both Python AND Tcl"
+       #if use python && use tcl; then
+       #       myconf+=( $(use_with tk tkinter) )
+       #else
+       #       myconf+=( --without-tkinter )
+       #fi
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.vm
+       newdoc cmdlang/README README.cmdlang
+
+       use python && python_optimize
+
+       find "${ED}" -name "*.la" -delete || die
+       if ! use static-libs ; then
+               find "${ED}" -name "*.a" -delete || die
+       fi
+}