sys-cluster/torque: adjust flags for modern toolchains
authorIan Stakenvicius <axs@gentoo.org>
Tue, 15 Oct 2019 20:43:34 +0000 (16:43 -0400)
committerIan Stakenvicius <axs@gentoo.org>
Tue, 15 Oct 2019 20:44:33 +0000 (16:44 -0400)
This is a workaround patch that supports building toqrue on
an at-time-of-commit stable stage3 environment.

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Ian Stakenvicius <axs@gentoo.org>
sys-cluster/torque/torque-6.0.4-r1.ebuild

index bc520dc0ace342c2a8b282fbf607826e6a7ca08e..1607c10d62d2b34e6d25195b625811cba511c281 100644 (file)
@@ -91,6 +91,10 @@ src_prepare() {
 }
 
 src_configure() {
+       append-cflags "-fpermissive"
+       use kernel_linux && append-cflags "-Dlinux"
+       append-cxxflags "-std=c++03"
+
        econf \
                $(use_enable tk gui) \
                $(use_enable tk tcl-qstat) \