dev-python/python-dateutil: version bump to 2.7.3
authorHenning Schild <henning@hennsch.de>
Fri, 17 Aug 2018 06:47:30 +0000 (08:47 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 18 Aug 2018 10:29:45 +0000 (12:29 +0200)
Signed-off-by: Henning Schild <henning@hennsch.de>
dev-python/python-dateutil/Manifest
dev-python/python-dateutil/python-dateutil-2.7.3.ebuild [new file with mode: 0644]

index e155f63b5c7d354f9ad6dc2425f7f9ba58510102..0412a8ee6195f4040dafc42dcf6511cd10f62da5 100644 (file)
@@ -1,3 +1,4 @@
 DIST python-dateutil-2.6.1.tar.gz 241428 BLAKE2B 93b1d43dacdfbf528b085864b04231c1a34b37b23bc64a58a0733f53ace0f7e0258ca58fbc725dc2aae15eebe8ed1f555b02862a4dfd360014e7ee9aa8d6a9f9 SHA512 f16dd29fc975629f594dd2683a525e2a86acb020bf8962558d19040b14ac6f19d4ab07a910d6bb55c9db3cc02b5472774a3a05ccc86cf624ca5e5144463646db
 DIST python-dateutil-2.7.1.tar.gz 298061 BLAKE2B a6bc2a3bf83ff234ddc53db5a3353b19303dd9e0c6d2d702537643e134508f96ccc69b962fd957d4cc754b07cd24b3c3c2ce07becc0add7db925b841d6a32b5d SHA512 3dbadeac3dd22bf51279c4237df96a925ed4063384a82e756a41e314c216751f2c90f8909a20ba96fdb065966034e9c7e40c1ea152876ca733a2176893c4deb2
 DIST python-dateutil-2.7.2.tar.gz 298000 BLAKE2B 4091108b125eb080809c74cdb53daa27973b2dc4b2c4f79eba2afb295fce7b6c21a8589d4643ad5af212900f55dc4139711929d5c7c4a2b094ac749d76125761 SHA512 b8fdc867aa67c4e5602bb3e9bf906dd4d32a6616fcdfd5f39d146d849a46d13c266bc9c2eae28490399fe608ba19dcb824d05ce96d556de07999449eaece7dfc
+DIST python-dateutil-2.7.3.tar.gz 302871 BLAKE2B 8b6cff6f977d52b64665f33d10513a638addada91a00192eb1f522aa9b239d5fb051bff3cfb837871ea61d7ab69994cfe5b42bb3b00851b5f15368c26db06fd7 SHA512 6b9973fa7db69d931bc6e772201c67bb7bbfa693ba35484d34960bd7e6227f2a2343df814a9fdbbff253e750299c48e7cdb2a609bf4522595df8a7fc595784fd
diff --git a/dev-python/python-dateutil/python-dateutil-2.7.3.ebuild b/dev-python/python-dateutil/python-dateutil-2.7.3.ebuild
new file mode 100644 (file)
index 0000000..cc406d8
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensions to the standard Python datetime module"
+HOMEPAGE="
+       https://dateutil.readthedocs.org/
+       https://pypi.org/project/python-dateutil
+       https://github.com/dateutil/dateutil/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/six-1.5[${PYTHON_USEDEP}]
+       sys-libs/timezone-data
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/freezegun[${PYTHON_USEDEP}]
+       )
+"
+
+python_prepare_all() {
+       local PATCHES=(
+               "${FILESDIR}"/0001-zoneinfo-Get-timezone-data-from-system-tzdata.patch
+       )
+
+       # don't install zoneinfo tarball
+       sed -i '/package_data=/d' setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       py.test -v || die "Tests failed under ${EPYTHON}"
+}