dev-python/pyx: clean old
authorAndrey Grozin <grozin@gentoo.org>
Sun, 8 Mar 2020 11:54:05 +0000 (18:54 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 8 Mar 2020 11:54:05 +0000 (18:54 +0700)
Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/pyx/Manifest
dev-python/pyx/pyx-0.12.1-r1.ebuild [deleted file]

index 735c1f390b31227f60ffd6c7835acdd6eac0579e..5a102d3091904827499f1c3e0950a4938b188533 100644 (file)
@@ -1,2 +1 @@
-DIST PyX-0.12.1.tar.gz 561989 BLAKE2B 894b507f78745e0688abca20db91f4161627812ce303a066dde64841a3ac4e6415e00fb76a9273b413ddd9dc72550726e2f39004c053c6350f4f76253b884be4 SHA512 4941f5aa21aff3743546495fb073c10d2657ff42b2aff401903498638093d0e31e344cce778980f28a7170c6d29eab72ac074277b9d4088376e8692dc71e55c1
 DIST PyX-0.14.1.tar.gz 2475186 BLAKE2B 5e18b2a052c586cfdcfcc46f5351683ce7c3ec41d508b6fd5e085be543ac3730ee866b636d3ab9663e782b95efafcc340260826c82a77955b586ad7a55676c5b SHA512 16265bbdcaf28ce194189a2987b32952f296c850b829454bcccce0abd23838bfca0276c3e9c8e96b8cbfaf1473bf14669f9b7f2032ee039b61ae59ea3aa45a20
diff --git a/dev-python/pyx/pyx-0.12.1-r1.ebuild b/dev-python/pyx/pyx-0.12.1-r1.ebuild
deleted file mode 100644 (file)
index 8e3c042..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="${P/pyx/PyX}"
-
-DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
-HOMEPAGE="https://pyx.sourceforge.net/
-       https://pypi.org/project/PyX/"
-SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="virtual/tex-base
-               dev-texlive/texlive-basic"
-
-DEPEND="${RDEPEND}
-       doc? ( virtual/latex-base
-               dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-       distutils-r1_src_prepare
-       sed -i \
-               -e 's/^build_t1code=.*/build_t1code=1/' \
-               -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
-               setup.cfg || die "setup.cfg fix failed"
-}
-
-python_compile_all() {
-       if use doc; then
-               VARTEXFONTS="${T}"/fonts emake -C "${S}"/faq latexpdf
-       fi
-}
-
-python_install_all() {
-       use doc && dodoc faq/_build/latex/pyxfaq.pdf
-       distutils-r1_python_install_all
-}