dev-python/eventlet: Remove old
authorDavid Seifert <soap@gentoo.org>
Thu, 19 Mar 2020 21:38:43 +0000 (22:38 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 19 Mar 2020 21:38:43 +0000 (22:38 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/eventlet/Manifest
dev-python/eventlet/eventlet-0.18.4.ebuild [deleted file]
dev-python/eventlet/eventlet-0.20.0-r1.ebuild [deleted file]
dev-python/eventlet/eventlet-0.20.1-r1.ebuild [deleted file]
dev-python/eventlet/eventlet-0.21.0-r1.ebuild [deleted file]
dev-python/eventlet/eventlet-0.24.1-r1.ebuild [deleted file]
dev-python/eventlet/eventlet-0.24.1.ebuild [deleted file]

index fd8c7fb24ca63bb7f4bdbb579a9cba510757b7bf..52d19056861a3b028065f32b2e52e7cdc30486ee 100644 (file)
@@ -1,6 +1 @@
-DIST eventlet-0.18.4.tar.gz 288920 BLAKE2B 497b5e154de495049e477ab54660fa4e5af978c5a2d4a8faa566a965ccbbc017aaf9fc14df6e763191ad2daac70c859b935bce6cc73c6c097bcadd507d738f55 SHA512 3098f2e8649b1e10157b9474571b372176b05263a7d5e7bb915b0464551d70505bbdf77dc072f64c1c05b3011406ae4814ea1b6f746cea766bb58827b1515fcc
-DIST eventlet-0.20.0.tar.gz 466828 BLAKE2B 43beb8f924c5e375a554db3fb90e3c39121ff9899aa1a214118531e3e6fa7711899f278b2187e1e61409a58c05e9bba1a8a6392e1b31a811ef1f32dd7b929016 SHA512 4be70ba8cc3ac76d424aad66cd214e97249a42785319b992d048a77cd26f53a428f7959596d07da9a88c92ee103d73d4990733fc00bca57cc8fd242041365348
-DIST eventlet-0.20.1.tar.gz 469509 BLAKE2B 727844b70c4e1874a58efc95551dd7f12bec1c8d01cadeaedbc49f00a86e1393b690076fe720e8efdf00107f72b892a3a1f4c4921f95656b904221e748df7f09 SHA512 875c1ca82822a486bf28866c7d1f34df2419e7d33450a21740434d2e7f15c37a1090436cb7fe1feaeb5c810d39e4b238206c502323317897c8a42e844cbe7734
-DIST eventlet-0.21.0.tar.gz 484191 BLAKE2B 07d3f5d1dca11032d51fef9ceb624e07da9e93bed914233da9abbdff27f21f2482b9e3417b50a63f383cae13615c6a781104a05dfb66f28d6ab4e469bce06ef9 SHA512 4ee682ca8faf870ff6f1d72e93527028f73ae13d7f755eceafb23f3cde48e52b83ff04b645b7e90299997713de93c52f244db8b81d6abc7788a56ea38c7b0f47
-DIST eventlet-0.24.1.tar.gz 391579 BLAKE2B f8abfe6d18ed3b2edf4b2fa3d197abdd1e9029dd10c035427a2ddcb70cdaa76da114083ce7016af7151927fcb2f93ce6ffa0417dbe1a125948318baaed2f6184 SHA512 867f8ead3a6c0dd692c5cc5d9f1181b04456bdb270ea95d84f7f97da4603b333df539721cda002437c035fac51134bee8cc3495e09b6a25ae1c46fdaf015d0c3
 DIST eventlet-0.25.1.tar.gz 392719 BLAKE2B 7dbc23e63e9dc8b8bb0b4a53fc07cb467661bd695b6c778b973bd690bd24f3dd0f867d7ed803e1a89ffd36e5597fd244ef2c616c663d3d9130033f5f5928e816 SHA512 936aac45e24b2797cc8b6cd6238d493ce5eb60a47096e13827b8be145bd8dd14503f5ae624485c87b163718a85733b2317688366ef5fdf347f7d367fbf4d521d
diff --git a/dev-python/eventlet/eventlet-0.18.4.ebuild b/dev-python/eventlet/eventlet-0.18.4.ebuild
deleted file mode 100644 (file)
index e888b1c..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/python-docs-2.7.6-r1:2.7 )
-       test? ( ${RDEPEND}
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       if use doc; then
-               local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
-               local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
-               local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
-               local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
-               sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
-       fi
-
-       if use test; then
-#              sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-#              sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-#              sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
-               sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
-       fi
-
-       # Prevent file collisions from teestsuite
-       sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/eventlet/eventlet/issues/152
-       use doc && emake -C doc html
-}
-
-python_test() {
-       # Several errors 1 failure
-       # https://github.com/eventlet/eventlet/issues/151
-       nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.20.0-r1.ebuild b/dev-python/eventlet/eventlet-0.20.0-r1.ebuild
deleted file mode 100644 (file)
index 2462674..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/python-docs-2.7.6-r1:2.7 )
-       test? ( ${RDEPEND}
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # provided by virtual/python-enum34
-       sed -i '/enum-compat/d' setup.py || die
-
-       if use doc; then
-               local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
-               local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
-               local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
-               local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
-               sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
-       fi
-
-       if use test; then
-#              sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-#              sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-#              sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
-               sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
-       fi
-
-       # Prevent file collisions from teestsuite
-       sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/eventlet/eventlet/issues/152
-       use doc && emake -C doc html
-}
-
-python_test() {
-       # Several errors 1 failure
-       # https://github.com/eventlet/eventlet/issues/151
-       nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.20.1-r1.ebuild b/dev-python/eventlet/eventlet-0.20.1-r1.ebuild
deleted file mode 100644 (file)
index 6c4784a..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/python-docs-2.7.6-r1:2.7 )
-       test? ( ${RDEPEND}
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # provided by virtual/python-enum34
-       sed -i '/enum-compat/d' setup.py || die
-
-       if use doc; then
-               local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
-               local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
-               local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
-               local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
-               sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
-       fi
-
-       if use test; then
-#              sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-#              sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-#              sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
-               sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
-       fi
-
-       # Prevent file collisions from teestsuite
-       sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/eventlet/eventlet/issues/152
-       use doc && emake -C doc html
-}
-
-python_test() {
-       # Several errors 1 failure
-       # https://github.com/eventlet/eventlet/issues/151
-       nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.21.0-r1.ebuild b/dev-python/eventlet/eventlet-0.21.0-r1.ebuild
deleted file mode 100644 (file)
index 0fc1187..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/python-docs-2.7.6-r1:2.7 )
-       test? ( ${RDEPEND}
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # provided by virtual/python-enum34
-       sed -i '/enum-compat/d' setup.py || die
-
-       if use doc; then
-               local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
-               local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
-               local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
-               local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
-               sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
-       fi
-
-       if use test; then
-#              sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-#              sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-#              sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
-               sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
-       fi
-
-       # Prevent file collisions from teestsuite
-       sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/eventlet/eventlet/issues/152
-       use doc && emake -C doc html
-}
-
-python_test() {
-       # Several errors 1 failure
-       # https://github.com/eventlet/eventlet/issues/151
-       nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.24.1-r1.ebuild b/dev-python/eventlet/eventlet-0.24.1-r1.ebuild
deleted file mode 100644 (file)
index 248d072..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
-       >=dev-python/greenlet-0.3[${PYTHON_USEDEP}]
-       >=dev-python/monotonic-1.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/python-docs-2.7.6-r1:2.7 )
-       test? ( ${RDEPEND}
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # provided by virtual/python-enum34
-       sed -i '/enum-compat/d' setup.py || die
-
-       if use doc; then
-               local PYTHON_DOC_ATOM=$(best_version -b dev-python/python-docs:2.7)
-               local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
-               local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
-               local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
-               sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
-       fi
-
-       if use test; then
-#              sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-#              sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-#              sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
-               sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
-       fi
-
-       # Prevent file collisions from teestsuite
-       sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/eventlet/eventlet/issues/152
-       use doc && emake -C doc html
-}
-
-python_test() {
-       # Several errors 1 failure
-       # https://github.com/eventlet/eventlet/issues/151
-       nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       if use examples; then
-               docompress -x "/usr/share/doc/${PF}/examples"
-               docinto examples
-               dodoc -r examples/.
-       fi
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/eventlet/eventlet-0.24.1.ebuild b/dev-python/eventlet/eventlet-0.24.1.ebuild
deleted file mode 100644 (file)
index 116384c..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Highly concurrent networking library"
-HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
-SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
-       >=dev-python/greenlet-0.3[${PYTHON_USEDEP}]
-       >=dev-python/monotonic-1.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               >=dev-python/python-docs-2.7.6-r1:2.7 )
-       test? ( ${RDEPEND}
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # provided by virtual/python-enum34
-       sed -i '/enum-compat/d' setup.py || die
-
-       if use doc; then
-               local PYTHON_DOC_ATOM=$(best_version -b dev-python/python-docs:2.7)
-               local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
-               local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
-               local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
-               sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
-       fi
-
-       if use test; then
-#              sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
-#              sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
-#              sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
-               sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
-       fi
-
-       # Prevent file collisions from teestsuite
-       sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://github.com/eventlet/eventlet/issues/152
-       use doc && emake -C doc html
-}
-
-python_test() {
-       # Several errors 1 failure
-       # https://github.com/eventlet/eventlet/issues/151
-       nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       if use examples; then
-               docompress -x "/usr/share/doc/${PF}/examples"
-               docinto examples
-               dodoc -r examples/.
-       fi
-       distutils-r1_python_install_all
-}