app-office/scribus: fix startup crash
authorBernd Waibel <waebbl@gmail.com>
Tue, 24 Mar 2020 18:53:16 +0000 (19:53 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 27 Mar 2020 10:08:04 +0000 (11:08 +0100)
The patch fixes the crash on startup, as well as a zlib package
finding related issue in src_configure. It also solves an issue
whith selecting the correct python implementation.

Bug: https://bugs.gentoo.rog/691684
Package-Manager: Portage-2.3.95, Repoman-2.3.21
Signed-off-by: Bernd Waibel <waebbl@gmail.com>
Closes: https://bugs.gentoo.org/691684
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
app-office/scribus/scribus-9999.ebuild

index 97d62f8d370d66154991268f6e1dd812f78068b9..9d0977e8bd7c4de434769818cf777f3e4ad27248 100644 (file)
@@ -80,18 +80,13 @@ PATCHES=(
        "${FILESDIR}"/${PN}-1.5.6-findhyphen.patch
 )
 
+CMAKE_BUILD_TYPE="Release"
+
 src_prepare() {
        cmake_src_prepare
 
        rm -r codegen/cheetah scribus/third_party/hyphen || die
 
-       cat > cmake/modules/FindZLIB.cmake <<- EOF || die
-       find_package(PkgConfig)
-       pkg_check_modules(ZLIB minizip zlib)
-       SET( ZLIB_LIBRARY \${ZLIB_LIBRARIES} )
-       SET( ZLIB_INCLUDE_DIR \${ZLIB_INCLUDE_DIRS} )
-       MARK_AS_ADVANCED( ZLIB_LIBRARY ZLIB_INCLUDE_DIR )
-       EOF
        sed \
                -e "/^\s*unzip\.[ch]/d" \
                -e "/^\s*ioapi\.[ch]/d" \
@@ -115,6 +110,7 @@ src_configure() {
                -DHAVE_PYTHON=ON
                -DWANT_DISTROBUILD=ON
                -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/
+               -DPython3_EXECUTABLE="${PYTHON}"
                -DWITH_BOOST=$(usex boost)
                -DWANT_DEBUG=$(usex debug)
                -DWANT_NOEXAMPLES=$(usex !examples)