net-analyzer/bro: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sat, 20 Apr 2019 08:09:35 +0000 (10:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 20 Apr 2019 08:09:35 +0000 (10:09 +0200)
Closes: https://bugs.gentoo.org/675014
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-analyzer/bro/Manifest [deleted file]
net-analyzer/bro/bro-2.4.1-r2.ebuild [deleted file]
net-analyzer/bro/files/bro-2.4.1-fix-python-install-dir.patch [deleted file]
net-analyzer/bro/files/bro-2.4.1-remove-unnecessary-remove.patch [deleted file]
net-analyzer/bro/metadata.xml [deleted file]
profiles/package.mask

diff --git a/net-analyzer/bro/Manifest b/net-analyzer/bro/Manifest
deleted file mode 100644 (file)
index 15f6c45..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST bro-2.4.1.tar.gz 15010455 BLAKE2B 34e087253a62ad3d6948e1175fa05c34ceac7298103aef40a0ce791e1e83c8495d6f65c9489d0e7214ff1b743db766dfbf7b44544f7796b7b1f70ee7a1bedc67 SHA512 4f7bf6c037fe7b16214830d2dba9f7abffd853f66030aa710fb9f174a475f8cd27d8de6bacf965f142f942a42093ceb78dcd8cbcedac6fbcfdd65ac07b3dd410
diff --git a/net-analyzer/bro/bro-2.4.1-r2.ebuild b/net-analyzer/bro/bro-2.4.1-r2.ebuild
deleted file mode 100644 (file)
index 68ee260..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_REQ_USE="sqlite"
-PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1
-
-DESCRIPTION="The Bro Network Security Monitor"
-HOMEPAGE="https://www.bro.org"
-SRC_URI="https://www.bro.org/downloads/release/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+broccoli +broctl -broker curl debug geoip ipv6 jemalloc +python -ruby tcmalloc static-libs +tools"
-
-RDEPEND="
-       app-shells/bash:0
-       dev-libs/openssl:0=
-       net-analyzer/ipsumdump
-       net-dns/bind-tools
-       net-libs/libpcap
-       sys-libs/zlib
-       broker? ( dev-libs/actor-framework:0/13.2 )
-       broctl? ( virtual/mta )
-       curl? ( net-misc/curl )
-       geoip? ( dev-libs/geoip )
-       ipv6? ( net-analyzer/ipsumdump[ipv6] )
-       jemalloc? ( dev-libs/jemalloc )
-       python? ( ${PYTHON_DEPS} )
-       ruby? ( >=dev-lang/ruby-1.8:= )
-       tcmalloc? ( dev-util/google-perftools )
-"
-DEPEND="${RDEPEND}
-       >=dev-lang/swig-3.0.3
-       dev-lang/perl
-"
-
-REQUIRED_USE="
-       broker? ( python )
-       broctl? ( python )
-       python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-PATCHES=(
-       "${FILESDIR}/bro-2.4.1-remove-unnecessary-remove.patch"
-       "${FILESDIR}/bro-2.4.1-fix-python-install-dir.patch"
-)
-
-pkg_setup() {
-       use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       # Disable shell script feature which sets interpreter to build time default
-       find . -name "*.cmake" -exec sed -i -e "s:\${\${_shell}_interp}:/usr/bin/env ${EPYTHON}:g" {} + || die
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DENABLE_DEBUG=$(usex debug true false)
-               -DENABLE_JEMALLOC=$(usex jemalloc true false)
-               -DDISABLE_PERFTOOLS=$(usex tcmalloc false true)
-               -DENABLE_BROKER=$(usex broker true false)
-               -DENABLE_CXX11=$(usex broker true false)
-               -DENABLE_STATIC=$(usex static-libs true false)
-               -DINSTALL_BROCCOLI=$(usex broccoli true false)
-               -DINSTALL_BROCTL=$(usex broctl true false)
-               -DINSTALL_AUX_TOOLS=$(usex tools true false)
-               -DENABLE_MOBILE_IPV6=$(usex ipv6 true false)
-               -DDISABLE_RUBY_BINDINGS=$(usex ruby false true)
-               -DDISABLE_PYTHON_BINDINGS=$(usex python false true)
-               -DBRO_LOG_DIR="/var/log/bro/"
-               -DBRO_SPOOL_DIR="/var/spool/bro/"
-               -DBRO_ETC_INSTALL_DIR="/etc/bro/"
-               -DINSTALL_LIB_DIR="/usr/$(get_libdir)"
-               -DPY_MOD_INSTALL_DIR="$(python_get_sitedir)"
-       )
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-       keepdir /var/log/bro /var/spool/bro/tmp
-       # Doesn't exist
-       rm -f "${ED}"/usr/share/broctl/scripts/broctl-config.sh
-}
diff --git a/net-analyzer/bro/files/bro-2.4.1-fix-python-install-dir.patch b/net-analyzer/bro/files/bro-2.4.1-fix-python-install-dir.patch
deleted file mode 100644 (file)
index 66d41ed..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/aux/broker/bindings/python/CMakeLists.txt        2016-03-17 23:26:42.707456012 +0100
-+++ b/aux/broker/bindings/python/CMakeLists.txt        2016-03-17 23:28:27.714453166 +0100
-@@ -52,19 +52,21 @@
- swig_add_module(pybroker python pybroker.i)
- swig_link_libraries(pybroker ${libbroker} ${PYTHON_LIBRARIES})
--if ( BROKER_PYTHON_PREFIX )
--    set(pyver ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
--    set(PY_MOD_INSTALL_DIR
--        ${BROKER_PYTHON_PREFIX}/lib/python${pyver}/site-packages)
--elseif ( BROKER_PYTHON_HOME )
--    set(PY_MOD_INSTALL_DIR ${BROKER_PYTHON_HOME}/lib/python)
--else ()
--    execute_process(COMMAND ${PYTHON_EXECUTABLE} -c
--        "from distutils.sysconfig import get_python_lib; print get_python_lib()"
--                    OUTPUT_VARIABLE PYTHON_SITE_PACKAGES
--                    OUTPUT_STRIP_TRAILING_WHITESPACE)
--    set(PY_MOD_INSTALL_DIR ${PYTHON_SITE_PACKAGES})
--endif ()
-+if ( NOT PY_MOD_INSTALL_DIR )
-+    if ( BROKER_PYTHON_PREFIX )
-+        set(pyver ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
-+        set(PY_MOD_INSTALL_DIR
-+            ${BROKER_PYTHON_PREFIX}/lib/python${pyver}/site-packages)
-+    elseif ( BROKER_PYTHON_HOME )
-+        set(PY_MOD_INSTALL_DIR ${BROKER_PYTHON_HOME}/lib/python)
-+    else ()
-+        execute_process(COMMAND ${PYTHON_EXECUTABLE} -c
-+            "from distutils.sysconfig import get_python_lib; print get_python_lib()"
-+                        OUTPUT_VARIABLE PYTHON_SITE_PACKAGES
-+                        OUTPUT_STRIP_TRAILING_WHITESPACE)
-+        set(PY_MOD_INSTALL_DIR ${PYTHON_SITE_PACKAGES})
-+    endif ( BROKER_PYTHON_PREFIX )
-+endif ( NOT PY_MOD_INSTALL_DIR )
- message(STATUS "Python bindings will be built and installed to: "
-                ${PY_MOD_INSTALL_DIR})
diff --git a/net-analyzer/bro/files/bro-2.4.1-remove-unnecessary-remove.patch b/net-analyzer/bro/files/bro-2.4.1-remove-unnecessary-remove.patch
deleted file mode 100644 (file)
index e4803bc..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/CMakeLists.txt.old   2016-03-11 20:47:44.652900344 +0100
-+++ b/src/CMakeLists.txt       2016-03-11 20:48:11.665101378 +0100
-@@ -425,10 +425,10 @@
- # Remove some stale files and scripts that previous Bro versions put in
- # place, yet make confuse us now. This makes upgrading easier.
--install(CODE "
--   file(REMOVE_RECURSE
--       ${BRO_SCRIPT_INSTALL_PATH}/base/frameworks/logging/writers/dataseries.bro
--       ${BRO_SCRIPT_INSTALL_PATH}/base/frameworks/logging/writers/elasticsearch.bro
--       ${BRO_SCRIPT_INSTALL_PATH}/policy/tuning/logs-to-elasticsearch.bro
--   )
--")
-+#install(CODE "
-+#   file(REMOVE_RECURSE
-+#       ${BRO_SCRIPT_INSTALL_PATH}/base/frameworks/logging/writers/dataseries.bro
-+#       ${BRO_SCRIPT_INSTALL_PATH}/base/frameworks/logging/writers/elasticsearch.bro
-+#       ${BRO_SCRIPT_INSTALL_PATH}/policy/tuning/logs-to-elasticsearch.bro
-+#   )
-+#")
diff --git a/net-analyzer/bro/metadata.xml b/net-analyzer/bro/metadata.xml
deleted file mode 100644 (file)
index 61a2fa9..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-    <use>
-        <flag name="broccoli">Enable the Bro Client Communication Library</flag>
-        <flag name="broctl">An interactive shell for managing Bro installations</flag>
-        <flag name="broker">Bro's new Messaging Library (experimental)</flag>
-        <flag name="geoip">Enable support for Maxmind's GeoIP library</flag>
-        <flag name="ipv6">Support for mobile IPv6</flag>
-        <flag name="python">Enable Python bindings</flag>
-        <flag name="ruby">Enable Ruby bindings (deprecated)</flag>
-        <flag name="tcmalloc">Enable Google's Performance Analysis Tools</flag>
-        <flag name="tools">Auxiliary tools for Bro: adtrace, bro-cut, devel-tools, rst</flag>
-    </use>
-    <longdescription lang="en">Bro is a powerful network analysis framework that is much different from the typical IDS you may know.
-    </longdescription>
-</pkgmetadata>
index 82d9c829d1ab50dcea532dc7bacbba80e64a9433..d4721863620d5fd5b3615186da0b222f5fe62a8d 100644 (file)
@@ -612,7 +612,6 @@ x11-libs/hippo-canvas
 # mail-client/nail: #676008, last commit in 2010, also #508480
 # mail-client/nmh: #676938, needs bump, 2014, also #676938, #680596
 # mail-filter/libdkim: #674892, no revdeps, last release in 2010
-# net-analyzer/bro: #675014, needs bump, current version is from 2015
 #
 # Removal in 30 days.
 app-crypt/keynote
@@ -622,7 +621,6 @@ games-util/gtkevemon
 mail-client/nail
 mail-client/nmh
 mail-filter/libdkim
-net-analyzer/bro
 
 # Miroslav Šulc <fordfrog@gentoo.org> (19 Mar 2019)
 # Depends on >=virtual/{jdk,jre}-11 which is masked