dev-ros/xacro: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 19:21:57 +0000 (21:21 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 19:22:09 +0000 (21:22 +0200)
Package-Manager: portage-2.2.21

dev-ros/xacro/Manifest [new file with mode: 0644]
dev-ros/xacro/metadata.xml [new file with mode: 0644]
dev-ros/xacro/xacro-1.10.6.ebuild [new file with mode: 0644]
dev-ros/xacro/xacro-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/xacro/Manifest b/dev-ros/xacro/Manifest
new file mode 100644 (file)
index 0000000..2082b63
--- /dev/null
@@ -0,0 +1 @@
+DIST xacro-1.10.6.tar.gz 78054 SHA256 6f3b7246465e61569dcae2e79575eb1cbce8ad73b41704c931fbf00466b3a106 SHA512 a41b56f501018c19cfcda988858635296d01210fc34d249906a938eb6daa041d8cf46679cd54da830d76e61a9693688f86adc5093ee2f202c843b7fdf017cb13 WHIRLPOOL f31a935134ca123a5e9a06a03756078756a579e41cfd78e88bb2b0fcf1bd92a9fa10a19da46d21e0fa9ae85d890d84f244dff7e954c7ba2bc657767d7e0ce434
diff --git a/dev-ros/xacro/metadata.xml b/dev-ros/xacro/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/xacro/xacro-1.10.6.ebuild b/dev-ros/xacro/xacro-1.10.6.ebuild
new file mode 100644 (file)
index 0000000..5065af8
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/xacro"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="XML macro language"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="${RDEPEND}
+       dev-ros/roslaunch[${PYTHON_USEDEP}]"
diff --git a/dev-ros/xacro/xacro-9999.ebuild b/dev-ros/xacro/xacro-9999.ebuild
new file mode 100644 (file)
index 0000000..5065af8
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/xacro"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="XML macro language"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="${RDEPEND}
+       dev-ros/roslaunch[${PYTHON_USEDEP}]"