dev-python/zope-event: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 10:06:04 +0000 (11:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:39:26 +0000 (14:39 +0100)
dev-python/zope-event/zope-event-4.2.0-r1.ebuild [deleted file]

diff --git a/dev-python/zope-event/zope-event-4.2.0-r1.ebuild b/dev-python/zope-event/zope-event-4.2.0-r1.ebuild
deleted file mode 100644 (file)
index beab379..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-MY_PN=zope.event
-
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
-HOMEPAGE="https://github.com/zopefoundation/zope.event http://docs.zope.org/zope.event/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
-       nosetests || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       # remove .pth files since dev-python/namespace-zope handles the ns
-       find "${D}" -name '*.pth' -delete || die
-}