media-video/transcode: add gcc-10 / -fno-common fix
authorBen Kohler <bkohler@gentoo.org>
Fri, 15 May 2020 16:23:38 +0000 (11:23 -0500)
committerBen Kohler <bkohler@gentoo.org>
Fri, 15 May 2020 16:23:58 +0000 (11:23 -0500)
Closes: https://bugs.gentoo.org/707162
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
media-video/transcode/files/transcode-1.1.7-gcc10-fno-common.patch [new file with mode: 0644]
media-video/transcode/transcode-1.1.7-r5.ebuild

diff --git a/media-video/transcode/files/transcode-1.1.7-gcc10-fno-common.patch b/media-video/transcode/files/transcode-1.1.7-gcc10-fno-common.patch
new file mode 100644 (file)
index 0000000..fcee415
--- /dev/null
@@ -0,0 +1,48 @@
+--- a/import/demux_pass.c
++++ b/import/demux_pass.c
+@@ -32,8 +32,6 @@
+ #include "packets.h"
+-int gop, gop_pts, gop_cnt;
+-
+ /* if you listen carefully, then you can hear the desesperate
+  * whisper of this code calling for a rewrite. Or for a redesign.
+  * Or both. --  FR
+--- a/import/extract_ac3.c
++++ b/import/extract_ac3.c
+@@ -334,7 +334,6 @@
+ FILE *fd;
+ #define MAX_BUF 4096
+-char audio[MAX_BUF];
+ /* from ac3scan.c */
+@@ -472,6 +471,8 @@
+ void extract_ac3(info_t *ipipe)
+ {
++    char audio[MAX_BUF];
++
+     int error=0;
+     avi_t *avifile;
+--- a/import/extract_mp3.c
++++ b/import/extract_mp3.c
+@@ -243,7 +243,6 @@
+ }
+ #define MAX_BUF 4096
+-char audio[MAX_BUF];
+ /* ------------------------------------------------------------
+  *
+@@ -258,6 +257,7 @@
+ void extract_mp3(info_t *ipipe)
+ {
++    char audio[MAX_BUF];
+     int error=0;
index 7a878b4fd54845686402adf409927353ac92083c..6af3a27f9474e2c24603e5e10b1b5ed69720f61b 100644 (file)
@@ -67,6 +67,7 @@ PATCHES=(
        "${WORKDIR}"/${P}-patchset/${P}-freetype251.patch
        "${WORKDIR}"/${P}-patchset/${P}-ffmpeg24.patch
        "${FILESDIR}"/${P}-swresample.patch #722296
+       "${FILESDIR}"/${P}-gcc10-fno-common.patch
 )
 
 src_prepare() {