version bump
authorAlin Năstac <mrness@gentoo.org>
Sat, 10 Feb 2007 08:18:20 +0000 (08:18 +0000)
committerAlin Năstac <mrness@gentoo.org>
Sat, 10 Feb 2007 08:18:20 +0000 (08:18 +0000)
Package-Manager: portage-2.1.1-r2

net-dialup/hcfpcimodem/ChangeLog
net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.11 [new file with mode: 0644]
net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild [new file with mode: 0644]
net-dialup/hcfusbmodem/ChangeLog
net-dialup/hcfusbmodem/files/digest-hcfusbmodem-1.11 [new file with mode: 0644]
net-dialup/hcfusbmodem/hcfusbmodem-1.11.ebuild [new file with mode: 0644]

index ac4564a35a0b8b88d20cbae92cafa860dbf30951..d0196959728c3f95ca4f45d596484d5b33987543 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-dialup/hcfpcimodem
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.26 2006/09/22 19:16:26 mrness Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.27 2007/02/10 08:15:52 mrness Exp $
+
+*hcfpcimodem-1.11 (10 Feb 2007)
+
+  10 Feb 2007; Alin Năstac <mrness@gentoo.org> +hcfpcimodem-1.11.ebuild:
+  Version bump.
 
   22 Sep 2006; Alin Nastac <mrness@gentoo.org>
   -files/hcfpcimodem-1.08-upstream-20051215.patch, -hcfpcimodem-1.08.ebuild,
diff --git a/net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.11 b/net-dialup/hcfpcimodem/files/digest-hcfpcimodem-1.11
new file mode 100644 (file)
index 0000000..7992acb
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 e6d8fea8f5f641d7bb4dfb33c6f478e7 100498D_RM_HxF_Released.pdf 718949
+RMD160 be9df1ae492bcce46775c0325cd438b91213bf7a 100498D_RM_HxF_Released.pdf 718949
+SHA256 e05385b094ac97f13aabc9432ba7478c0acf12862b3c4da097272435d43f6ac1 100498D_RM_HxF_Released.pdf 718949
+MD5 6bb1a6ea10bbf8d971222104071f8291 hcfpcimodem-1.11full.tar.gz 677772
+RMD160 b1cc280c6511176c215b33124098072f7449eb5d hcfpcimodem-1.11full.tar.gz 677772
+SHA256 a1c8f8a2d6818d3f1c2da0372383be0e68c887b610f3f8135f640e136dc3e0fe hcfpcimodem-1.11full.tar.gz 677772
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild
new file mode 100644 (file)
index 0000000..81104cd
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/hcfpcimodem-1.11.ebuild,v 1.1 2007/02/10 08:15:52 mrness Exp $
+
+inherit eutils linux-info
+
+#The document is the same as in hsfmodem, even if it has a different URL
+MY_DOC="100498D_RM_HxF_Released.pdf"
+
+DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
+HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
+       doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
+
+LICENSE="Conexant"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+       app-arch/cpio"
+
+S="${WORKDIR}/${P}full"
+
+QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
+
+pkg_setup() {
+       linux-info_pkg_setup
+
+       MOD_N="hcfpci"
+       # Check to see if module is inserted into kernel, otherwise, build fails
+       if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+               eerror
+               eerror "Module is in use by the kernel!!!"
+               eerror "Attempting to unload..."
+               eerror
+
+               # Unloading module...
+               ${MOD_N}stop
+               if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+                       eerror "Failed to unload modules from kernel!!!"
+                       eerror "Please manualy remove the module from the kernel and emerge again."
+                       eerror
+                       die
+               fi
+               einfo "Successfuly removed module from memory.  Resuming emerge."
+               einfo
+       fi
+}
+
+src_compile() {
+       emake all || die "make failed"
+}
+
+pkg_preinst() {
+       local NVMDIR="${ROOT}/etc/${PN}/nvm"
+       if [ -d "${NVMDIR}" ]; then
+               einfo "Cleaning ${NVMDIR}..."
+               rm -rf "${NVMDIR}"
+               eend
+       fi
+}
+
+src_install () {
+       make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+
+       use doc && dodoc "${DISTDIR}/${MY_DOC}"
+}
+
+pkg_postinst() {
+       einfo "To complete the installation and configuration of your HCF modem,"
+       einfo "please run hcfpciconfig."
+}
+
index 01cd01b6d63fe8d927e53262c713c10bbf9f1da6..2623e20cfcedf0e9dac8cb660e782a86531aa19e 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-dialup/hcfusbmodem
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfusbmodem/ChangeLog,v 1.19 2006/09/22 19:14:00 mrness Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfusbmodem/ChangeLog,v 1.20 2007/02/10 08:18:20 mrness Exp $
+
+*hcfusbmodem-1.11 (10 Feb 2007)
+
+  10 Feb 2007; Alin Năstac <mrness@gentoo.org> +hcfusbmodem-1.11.ebuild:
+  Version bump.
 
   22 Sep 2006; Alin Nastac <mrness@gentoo.org> hcfusbmodem-1.10.ebuild:
   Deactivate exec stack QA warning.
diff --git a/net-dialup/hcfusbmodem/files/digest-hcfusbmodem-1.11 b/net-dialup/hcfusbmodem/files/digest-hcfusbmodem-1.11
new file mode 100644 (file)
index 0000000..071a776
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9db469c987e2615c82028f95ee3d87af hcfusbmodem-1.11powerpcfull.tar.gz 614059
+RMD160 c3382e24d60045f8fc6836c5e857460c61254642 hcfusbmodem-1.11powerpcfull.tar.gz 614059
+SHA256 4952a03977188dc0c084274566b619b717563651da992a0265d21281dc97191e hcfusbmodem-1.11powerpcfull.tar.gz 614059
diff --git a/net-dialup/hcfusbmodem/hcfusbmodem-1.11.ebuild b/net-dialup/hcfusbmodem/hcfusbmodem-1.11.ebuild
new file mode 100644 (file)
index 0000000..d8d3064
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfusbmodem/hcfusbmodem-1.11.ebuild,v 1.1 2007/02/10 08:18:20 mrness Exp $
+
+inherit linux-info eutils
+
+DESCRIPTION="hcfusbmodem - Modem driver for Connexant HSF chipset"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}powerpcfull.tar.gz"
+HOMEPAGE="http://www.linuxant.com/drivers/"
+
+IUSE=""
+SLOT="0"
+LICENSE="Conexant"
+KEYWORDS="-* ~ppc"
+
+DEPEND="dev-lang/perl
+       app-arch/cpio"
+
+S="${WORKDIR}/${P}powerpcfull"
+
+QA_EXECSTACK="usr/lib/hcfusbmodem/modules/imported/hcfblam-powerpc.O usr/lib/hcfusbmodem/modules/imported/hcfengine-powerpc.O"
+
+src_compile() {
+       emake all || die "make failed"
+}
+
+src_install () {
+       make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+       einfo "To complete the installation and configuration of your HCF modem,"
+       einfo "please run hcfusbconfig."
+}