use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 18:56:48 +0000 (18:56 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 18:56:48 +0000 (18:56 +0000)
Package-Manager: portage-2.1.2.3

games-emulation/pcsx2/pcsx2-0.6.ebuild
games-emulation/pcsx2/pcsx2-0.8.1.ebuild
games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild

index 30f40f21f5e7abdcac5b4d85febf274021485ddf..14e3929258cf14c92baaad277694097fd87b959e 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.6.ebuild,v 1.7 2006/02/11 19:55:21 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.6.ebuild,v 1.8 2007/04/06 18:53:44 nyhm Exp $
 
 inherit eutils games
 
@@ -45,11 +45,11 @@ src_install() {
        dogamesbin "${FILESDIR}/pcsx2" || die "dogamesbin failed"
        sed -i \
                -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
-               -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+               -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
                "${D}/${GAMES_BINDIR}/pcsx2" \
                || die "sed failed"
-       dodir "${GAMES_LIBDIR}/ps2emu/Langs"
-       cp -r Intl/Langs/* "${D}/${GAMES_LIBDIR}/ps2emu/Langs/" || die "cp failed"
+       dodir "$(games_get_libdir)/ps2emu/Langs"
+       cp -r Intl/Langs/* "${D}/$(games_get_libdir)/ps2emu/Langs/" || die "cp failed"
        dodoc Docs/*.txt
        prepgamesdirs
 }
index b9fc7aba63577ede8b85d271fb64505af441826d..e7169001579632c6f594d44ac4e7e68c656461ec 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.7 2006/05/02 21:53:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.8 2007/04/06 18:53:44 nyhm Exp $
 
 inherit eutils toolchain-funcs games
 
@@ -53,7 +53,7 @@ src_install() {
        dogamesbin "${FILESDIR}/pcsx2" || die "dogamesbin failed"
        sed -i \
                -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
-               -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+               -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
                "${D}/${GAMES_BINDIR}/pcsx2" \
                || die "sed failed"
        dodoc Docs/*.txt
index 131e056d8c04cf0a709565ad8b103535288b45a8..63a26f6085406389ff125f4e58a6bc73a32f791c 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.6 2004/11/03 00:16:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.7 2007/04/06 18:56:48 nyhm Exp $
 
 inherit games
 
@@ -17,12 +17,13 @@ RDEPEND="=x11-libs/gtk+-1*"
 DEPEND="${RDEPEND}
        app-arch/unzip"
 
-S="${WORKDIR}/CDVDlinuz"
+S=${WORKDIR}/CDVDlinuz
 
 src_unpack() {
        unpack ${A}
+       cd "${S}"
        sed -i \
-               -e 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' ${S}/Src/Makefile \
+               -e 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' Src/Makefile \
                || die "sed failed"
 }
 
@@ -33,7 +34,7 @@ src_compile() {
 
 src_install() {
        dodoc ReadMe.txt
-       exeinto ${GAMES_LIBDIR}/ps2emu/plugins
-       newexe Src/libCDVDlinuz.so libCDVDlinuz-${PV}.so
+       exeinto "$(games_get_libdir)"/ps2emu/plugins
+       newexe Src/libCDVDlinuz.so libCDVDlinuz-${PV}.so || die "newexe failed"
        prepgamesdirs
 }