dev-ruby/tty-cursor: initial import of 0.7.0
authorHans de Graaff <graaff@gentoo.org>
Sun, 16 Jun 2019 05:10:04 +0000 (07:10 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 16 Jun 2019 06:37:54 +0000 (08:37 +0200)
Dependency for forthcoming dev-ruby/tty-reader

Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ruby/tty-cursor/Manifest [new file with mode: 0644]
dev-ruby/tty-cursor/metadata.xml [new file with mode: 0644]
dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/tty-cursor/Manifest b/dev-ruby/tty-cursor/Manifest
new file mode 100644 (file)
index 0000000..301fca5
--- /dev/null
@@ -0,0 +1 @@
+DIST tty-cursor-0.7.0.gem 11776 BLAKE2B 5dea8f2bde63f803639b4300bf3a8b22a89de7a20530ede38f75bdae7fbb522fe70adb0c78e20cc45e8001dba9fb378722f9fce6d26a68c0af00b7bc98a62a96 SHA512 00de195ba183174ebd10da7f1fdbb436a17fe9befc6eacb2d4cf4b1505be2c7d0719c0dc32d75a82900b2252ffbed00219ce31836c442b63c267e26dad40da63
diff --git a/dev-ruby/tty-cursor/metadata.xml b/dev-ruby/tty-cursor/metadata.xml
new file mode 100644 (file)
index 0000000..87a0450
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>ruby@gentoo.org</email>
+               <name>Gentoo Ruby Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">piotrmurach/tty-cursor</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..560f169
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Move the terminal cursor around and manipulate text using intuitive method calls"
+HOMEPAGE="https://github.com/piotrmurach/tty-cursor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+       echo '-rspec_helper' > .rspec || die
+}