sys-cluster/onesis: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 10:31:53 +0000 (11:31 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:24:37 +0000 (12:24 +0100)
Closes: https://bugs.gentoo.org/697176
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-cluster/onesis/onesis-2.0.2.ebuild

index 3c06451f906ca0933d0faaae578ac75aee8cfdc9..e115906bcab6dfb22f37b331c063d01d54cfcae0 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 MY_P="oneSIS-${PV/_}"
 
@@ -9,7 +9,7 @@ DESCRIPTION="Diskless computing made easy"
 HOMEPAGE="http://onesis.org/"
 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
 IUSE=""
@@ -20,5 +20,5 @@ RDEPEND="${DEPEND}"
 S="${WORKDIR}"/${MY_P}
 
 src_install() {
-       make prefix="${D}" INSTALLDIRS=vendor install || die "make install failed"
+       emake prefix="${D}" INSTALLDIRS=vendor install
 }