app-editors/pluma: Bump to 1.22.2
authorAdam Feldman <NP-Hardass@gentoo.org>
Wed, 4 Mar 2020 04:24:34 +0000 (23:24 -0500)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:47:48 +0000 (13:47 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
app-editors/pluma/Manifest
app-editors/pluma/pluma-1.22.2.ebuild [new file with mode: 0644]

index d4c3883b08aef5e66ad7ea50dca07179075516f2..1033e6f749126fcb89d1b811008bfbf5a77ed7b3 100644 (file)
@@ -1,2 +1,3 @@
 DIST pluma-1.22.0.tar.xz 3235612 BLAKE2B a0cda23a6ee73e562cb32c3f1430590042248b6a6e7cbf021103db507450b2a594506f3d8283eeed08e2ba5006ff51376eb6db5e94ea5ac9d5707b29e0efc2c4 SHA512 7c74c2ce0a89ec3813c936449d3114957e7b319433875ef567ecc508a28a1d3ddc3d0da418b2eb1278b6dc9dbaa3c75a279524f5a061b5aecb52955edcf28f51
 DIST pluma-1.22.1.tar.xz 3236724 BLAKE2B f571ccb79ffac11122dad1888a9804fdb1671f2c73b28c216e0ec593ffc4dac3fec3053b83fd1503e0c951e032f6e4c22fb4f3d6a1d23477a54e06de2659222e SHA512 0d3f07b2e8c736c9e1ad64ed5cb749db6088868e9bc27aa786cbb0c3fe72715f0fd4dd53999502a4333ec82110148b772c0dde81433d0936d2d3c2d04804026a
+DIST pluma-1.22.2.tar.xz 3262288 BLAKE2B 0a7af4318ec11aa6a01dd14ed071975b6a961747c1abda9120912244f3fd530c5c06e2fc9dad6ad23175c119e35c1380e88be4b9bc1e331485b646dee87af8e1 SHA512 a68b79713f649def15ea29e58e041d70bb6d756a356743f6e06d8dd680f7b39e8bcdd90c68cbe5c517bead7f9263d7596954bc595c3a2501edf0d0ea421c9992
diff --git a/app-editors/pluma/pluma-1.22.2.ebuild b/app-editors/pluma/pluma-1.22.2.ebuild
new file mode 100644 (file)
index 0000000..9e1d789
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1 virtualx
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+introspection spell"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
+# https://github.com/mate-desktop/mate-text-editor/issues/33
+RESTRICT="test"
+
+COMMON_DEPEND="dev-libs/atk
+       >=dev-libs/glib-2.50:2
+       >=dev-libs/libpeas-1.2.0[gtk]
+       >=dev-libs/libxml2-2.5:2
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/gtk+-3.22:3[introspection?]
+       >=x11-libs/gtksourceview-3.0.0:3.0
+       x11-libs/libICE
+       x11-libs/libX11
+       >=x11-libs/libSM-1.0
+       x11-libs/pango
+       virtual/libintl
+       introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+       spell? (
+               >=app-text/enchant-1.6:=
+               >=app-text/iso-codes-0.35
+       )
+       !!app-editors/mate-text-editor"
+
+RDEPEND="${PYTHON_DEPS}
+       ${COMMON_DEPEND}
+       >=mate-base/mate-desktop-1.9[introspection?]"
+
+DEPEND="${COMMON_DEPEND}
+       ~app-text/docbook-xml-dtd-4.1.2
+       app-text/rarian
+       >=app-text/scrollkeeper-dtd-1:1.0
+       app-text/yelp-tools
+       dev-util/glib-utils
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=dev-util/intltool-0.50.1
+       >=sys-devel/libtool-2.2.6:2
+       >=sys-devel/gettext-0.17
+       virtual/pkgconfig"
+
+src_configure() {
+       mate_src_configure \
+               $(use_enable introspection) \
+               $(use_enable spell)
+}
+
+src_test() {
+       # FIXME: This should be handled at eclass level.
+       "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+       unset DBUS_SESSION_BUS_ADDRESS
+
+       GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}