sys-libs/db: Fixed regressions introduced by commit a429a28d
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 12 Nov 2019 13:22:53 +0000 (14:22 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 12 Nov 2019 13:22:53 +0000 (14:22 +0100)
Closes: https://bugs.gentoo.org/699940
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
12 files changed:
sys-libs/db/db-18.1.32.ebuild
sys-libs/db/db-4.4.20_p4-r2.ebuild
sys-libs/db/db-4.5.20_p2-r2.ebuild
sys-libs/db/db-4.6.21_p4-r1.ebuild
sys-libs/db/db-4.7.25_p4-r1.ebuild
sys-libs/db/db-4.8.30-r3.ebuild
sys-libs/db/db-5.1.29-r2.ebuild
sys-libs/db/db-5.3.28-r2.ebuild
sys-libs/db/db-5.3.28-r4.ebuild
sys-libs/db/db-6.0.35-r2.ebuild
sys-libs/db/db-6.1.38.ebuild
sys-libs/db/db-6.2.38.ebuild

index f1e091a2851eb6341366b2bb8aee67863bc48fe0..b44531fc25ed47a1eb8e1e4e71b0e23983575327 100644 (file)
@@ -53,7 +53,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-6.2.32-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # sqlite configure call has an extra leading ..
        # upstreamed:5.2.36, missing in 5.3.x/6.x
index f96efa921c539dcf2247d3f7838498faf381015d..ba34f3c14a1466fe0e090948b5500d4aa1272aa2 100644 (file)
@@ -42,8 +42,8 @@ PATCHES=(
        "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
 
        # use the includes from the prefix
-       "${FILESDIR}"/"${PN}"-4.3-jni-check-prefix-first.patch
-       "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/"${PN}"-4.2-jni-check-prefix-first.patch
+       "${FILESDIR}"/"${PN}"-4.2-listen-to-java-options.patch
 )
 
 # Required to avoid unpack attempt of patches
index 8f2961315d99e7d24a70a90f21c212042e13991d..b0224a1b6b35e87e6b3c3b9f6090cde8fad3d731 100644 (file)
@@ -41,8 +41,8 @@ PATCHES=(
        "${FILESDIR}"/"${PN}"-4.4-libtool.patch
 
        # use the includes from the prefix
-       "${FILESDIR}"/"${PN}"-4.3-jni-check-prefix-first.patch
-       "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/"${PN}"-4.2-jni-check-prefix-first.patch
+       "${FILESDIR}"/"${PN}"-4.2-listen-to-java-options.patch
 )
 
 # Required to avoid unpack attempt of patches
index 2d57363d79579b6521b95583211e6c5b3fbf74e4..ac6d71e9f2f738757a623c06a0794cc193d0b4dd 100644 (file)
@@ -42,7 +42,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
-       "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/"${PN}"-4.2-listen-to-java-options.patch
 )
 
 # Required to avoid unpack attempt of patches
index 7309f2c920184dd4d8789206c4c0c942ded4ad4a..58f152d09e460d3049e35f7a64090201a6dc005a 100644 (file)
@@ -41,11 +41,11 @@ RDEPEND="tcl? ( dev-lang/tcl )
        java? ( >=virtual/jre-1.5 )"
 
 PATCHES=(
-       "${FILESDIR}"/"${PN}"-4.6-libtool.patch
+       "${FILESDIR}"/"${PN}"-4.4-libtool.patch
 
        # use the includes from the prefix
        "${FILESDIR}"/"${PN}"-4.6-jni-check-prefix-first.patch
-       "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/"${PN}"-4.2-listen-to-java-options.patch
 )
 
 # Required to avoid unpack attempt of patches
index 72e1ebf21a930d965acef381b7a1a430bf38bbd3..2ab7720ed8e0d11edc1d466e641cac46b7d8f2b5 100644 (file)
@@ -49,7 +49,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 )
 
 src_prepare() {
index e756c205a3cf24317af498e9ac7fcc06c8180421..fa1ad448f712dc9c9cee97332a97a848ca448fcd 100644 (file)
@@ -48,7 +48,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # upstream autoconf fails to build DBM when it's supposed to
        # merged upstream in 5.0.26
index ab3e1ac51059b5ae5af2ce8beb2c07ab608c380e..65935b031707b908be2738ed439d5b00bfd4669f 100644 (file)
@@ -58,7 +58,7 @@ src_prepare() {
 
        # use the includes from the prefix
        epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
-       epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       epatch "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # sqlite configure call has an extra leading ..
        # upstreamed:5.2.36, missing in 5.3.x
index feb6b08177b562cf7acb1bfc83f7448716c732a8..d7e61dc35ab26c831cd6685dc6090fa555a0fd9a 100644 (file)
@@ -52,7 +52,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # sqlite configure call has an extra leading ..
        # upstreamed:5.2.36, missing in 5.3.x
@@ -88,7 +88,7 @@ src_prepare() {
        # This supersedes the unused jarlocation patches.
        sed -r \
                -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
-               dist/Makefile.in || die
+               -i dist/Makefile.in || die
 
        cd dist || die
        rm aclocal/libtool.m4 || die
index d64d2ecb9bf6424146b17666cba9929d45127c25..b10a1424460f2e7e2b9188c0c7435ed23a008659 100644 (file)
@@ -52,7 +52,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # sqlite configure call has an extra leading ..
        # upstreamed:5.2.36, missing in 5.3.x/6.x
index e1ebf51e41f4071417cd146c6f5edec1785540cb..fa361fed901269a5eb544aa53734947644a3b7cf 100644 (file)
@@ -52,7 +52,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-6.2-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # sqlite configure call has an extra leading ..
        # upstreamed:5.2.36, missing in 5.3.x/6.x
index 37e88ebf6652e669eaa5c4eef6e4be83a41bdfcc..574e8c6fda318e5249136afac5bd2d32bf828ab6 100644 (file)
@@ -52,7 +52,7 @@ PATCHES=(
 
        # use the includes from the prefix
        "${FILESDIR}"/${PN}-6.2.32-jni-check-prefix-first.patch
-       "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
+       "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
 
        # sqlite configure call has an extra leading ..
        # upstreamed:5.2.36, missing in 5.3.x/6.x