kde-misc/semantik: explicitly export src_prepare.
authorMichael Palimaka <kensington@gentoo.org>
Mon, 24 Aug 2015 16:36:08 +0000 (02:36 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Mon, 24 Aug 2015 16:38:12 +0000 (02:38 +1000)
The removal of the base.eclass inherit from waf-utils.eclass resulted in
src_prepare no longer being exported. This caused a sandbox violation due
to a patch no longer being applied.

Gentoo-bug: 558514

Package-Manager: portage-2.2.20.1

kde-misc/semantik/semantik-0.9.4-r1.ebuild

index 56cb803953714e12c30c5cef5ad077b2c734429b..eca76785fb98ece3fc4c629ffc4eec4c341ac4bf 100644 (file)
@@ -8,7 +8,7 @@ CMAKE_REQUIRED="never"
 NO_WAF_LIBDIR="true"
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="xml"
-inherit python-single-r1 kde4-base waf-utils
+inherit eutils python-single-r1 kde4-base waf-utils
 
 DESCRIPTION="Mindmapping-like tool for document generation"
 HOMEPAGE="http://freehackers.org/~tnagy/semantik.html https://code.google.com/p/semantik/"
@@ -31,9 +31,12 @@ DEPEND="
 RDEPEND="${DEPEND}"
 
 DOCS=( ChangeLog README TODO )
-PATCHES=( "${FILESDIR}"/${PN}-0.9.0-wscript_ldconfig.patch )
 
 pkg_setup() {
        python-single-r1_pkg_setup
        kde4-base_pkg_setup
 }
+
+src_prepare() {
+       epatch "${FILESDIR}/${PN}-0.9.0-wscript_ldconfig.patch"
+}