sys-auth/elogind: Fix build with +selinux
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 12 Mar 2020 21:42:17 +0000 (22:42 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 12 Mar 2020 22:15:26 +0000 (23:15 +0100)
Closes: https://bugs.gentoo.org/711432
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-auth/elogind/elogind-243.4.ebuild
sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch [new file with mode: 0644]

index 1817a25b51c0850849e5a2fb36f9aebe80ce4423..0a185cec612992daf9c06b8a2a1aae304ef7ad4e 100644 (file)
@@ -50,6 +50,7 @@ DOCS=( README.md src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
 PATCHES=(
        "${FILESDIR}/${P}-nodocs.patch"
        "${FILESDIR}/${PN}-241.4-broken-test.patch" # bug 699116
+       "${FILESDIR}/${P}-selinux-missing-headers.patch" # bug 711432
 )
 
 pkg_setup() {
diff --git a/sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch b/sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch
new file mode 100644 (file)
index 0000000..7cc46fd
--- /dev/null
@@ -0,0 +1,36 @@
+From 1cd3fe4083eb8784fa2a125e4af0edb80e6928b5 Mon Sep 17 00:00:00 2001
+From: Sven Eden <sven.eden@prydeworx.com>
+Date: Thu, 12 Mar 2020 20:31:00 +0100
+Subject: [PATCH] basic/selinux-util.c : Uncomment missing includes (#157)
+
+Compiling on Debian unstable failed using gcc 9.2.1 and libc6 2.29.
+Uncommenting the two commented includes in basic/selinux-util.c
+fixes the compilation issues.
+
+Bug: #157
+Closes: #157
+Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
+---
+ src/basic/selinux-util.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/basic/selinux-util.c b/src/basic/selinux-util.c
+index 40a85feec..3be9f2c0d 100644
+--- a/src/basic/selinux-util.c
++++ b/src/basic/selinux-util.c
+@@ -1,13 +1,13 @@
+ /* SPDX-License-Identifier: LGPL-2.1+ */
+ #include <errno.h>
+-//#include <fcntl.h>
++#include <fcntl.h>
+ #include <malloc.h>
+ #include <stddef.h>
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+-//#include <sys/types.h>
++#include <sys/types.h>
+ #include <sys/un.h>
+ #include <syslog.h>