dev-libs/folks: fix USE=bluetooth build with meson-0.53
authorMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 12:29:50 +0000 (14:29 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 12:30:48 +0000 (14:30 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/folks/files/0.12.1-meson-0.53-compat.patch [new file with mode: 0644]
dev-libs/folks/folks-0.12.1-r1.ebuild

diff --git a/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch b/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch
new file mode 100644 (file)
index 0000000..56f9543
--- /dev/null
@@ -0,0 +1,47 @@
+From 1853567d79024c6ce960d9dc187cff8aaf9a37ce Mon Sep 17 00:00:00 2001
+From: Niels De Graef <nielsdegraef@gmail.com>
+Date: Mon, 3 Feb 2020 08:57:52 +0100
+Subject: [PATCH] meson: Use python.dependency() correctly
+
+From https://github.com/mesonbuild/meson/issues/6470:
+
+> So, to further clarify, passing an argument to
+> py_installation.dependency() should be an error, since this method
+> will only ever return a python dependency (for embedding python
+> itself, etc.) and not dbusmock or anything else.
+
+Fixxes https://gitlab.gnome.org/GNOME/folks/issues/119
+---
+ meson.build | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index d5115e28..f3644457 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,7 +1,7 @@
+ project('folks', [ 'vala', 'c' ],
+   version: '0.13.2',
+   license: 'LGPL2.1+',
+-  meson_version: '>= 0.49',
++  meson_version: '>= 0.51',
+ )
+ gnome = import('gnome')
+@@ -132,8 +132,11 @@ if bluez_backend_enabled
+   libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+   # Needed for the BlueZ tests
+   pymod = import('python')
+-  py_installation = pymod.find_installation('python3')
+-  python_dbusmock = py_installation.dependency('dbusmock')
++  py_installation = pymod.find_installation('python3',
++    modules: [
++      'dbusmock',
++    ],
++  )
+ endif
+ if import_tool_enabled
+-- 
+2.20.1
+
index 65b227ad231938441ea12431d2f49c78a8eb2435..51ddb26a5e316c99540d7d035b3e5f509a231d45 100644 (file)
@@ -49,6 +49,7 @@ BDEPEND="
 PATCHES=(
        "${FILESDIR}"/${PV}-conditional-tests.patch # Allow not building lots of test executables when tests are disabled
        "${FILESDIR}"/${PV}-no-tracker-tests.patch # TODO: Tracker tests fail; this removed them for now
+       "${FILESDIR}"/${PV}-meson-0.53-compat.patch # https://gitlab.gnome.org/GNOME/folks/issues/119
 )
 
 src_prepare() {