net-misc/apt-cacher-ng: Fix expire-caller.pl, disable by default
authorJeroen Roovers <jer@gentoo.org>
Tue, 26 May 2020 13:18:21 +0000 (15:18 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 26 May 2020 13:19:16 +0000 (15:19 +0200)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1-r1.ebuild [moved from net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1.ebuild with 96% similarity]
net-misc/apt-cacher-ng/apt-cacher-ng-9999999.ebuild
net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch [new file with mode: 0644]

similarity index 96%
rename from net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1.ebuild
rename to net-misc/apt-cacher-ng/apt-cacher-ng-3.5_p1-r1.ebuild
index 4061fff1f9ca5e15c83db88d5b8d226a52bebb53..97eab60040b873e83e26692bb86ab19da588523e 100644 (file)
@@ -43,6 +43,7 @@ RDEPEND="
 "
 PATCHES=(
        "${FILESDIR}"/${PN}-3.3.1-flags.patch
+       "${FILESDIR}"/${PN}-3.5-perl-syntax.patch
        "${WORKDIR}"/debian/patches/debian-changes
 )
 S=${WORKDIR}/${P/_*}
@@ -121,8 +122,8 @@ src_install() {
 
        # perl daily cron script
        dosbin scripts/expire-caller.pl
-       exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/cron.daily ${PN}
+       insinto /etc/cron.daily
+       doins "${FILESDIR}"/cron.daily ${PN}
 
        # default configuration
        insinto /etc/${PN}
index 402b95991acf173241ff17ce7d5dff00abf46714..9740af934f32cca09f3d00007fa859f3a72d0540 100644 (file)
@@ -40,6 +40,7 @@ RDEPEND="
        tcpd? ( sys-apps/tcp-wrappers )
 "
 PATCHES=(
+       "${FILESDIR}"/${PN}-3.5-perl-syntax.patch
        "${FILESDIR}"/${PN}-9999999-flags.patch
 )
 S=${WORKDIR}/${P/_*}
@@ -113,8 +114,8 @@ src_install() {
 
        # perl daily cron script
        dosbin scripts/expire-caller.pl
-       exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/cron.daily ${PN}
+       insinto /etc/cron.daily
+       doins "${FILESDIR}"/cron.daily ${PN}
 
        # default configuration
        insinto /etc/${PN}
diff --git a/net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch b/net-misc/apt-cacher-ng/files/apt-cacher-ng-3.5-perl-syntax.patch
new file mode 100644 (file)
index 0000000..32421a0
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/scripts/expire-caller.pl
++++ b/scripts/expire-caller.pl
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl
+ #
+-print STDERR "WARNING: this script is considered deprecated. It may still work but could print incorrect results!\n"
++print STDERR "WARNING: this script is considered deprecated. It may still work but could print incorrect results!\n";
+ use strict;
+ use Socket;