app-arch/unar: EAPI 6, slot ops, sort deps, missing || die
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 23 May 2018 14:54:06 +0000 (16:54 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 23 May 2018 14:59:28 +0000 (16:59 +0200)
Package-Manager: Portage-2.3.38, Repoman-2.3.9

app-arch/unar/unar-1.10.1.ebuild

index b482d11dbaba8aa64556d66b6c805827974c2029..e81a5cd054250c880c1b7851a25121e15e1ee9e7 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
 inherit toolchain-funcs
 
@@ -14,20 +14,24 @@ SLOT="0"
 KEYWORDS="amd64"
 IUSE=""
 
-RDEPEND="gnustep-base/gnustep-base
+RDEPEND="
+       app-arch/bzip2:=
        dev-libs/icu:=
-       sys-libs/zlib
-       app-arch/bzip2"
+       gnustep-base/gnustep-base
+       sys-libs/zlib:=
+"
 DEPEND="${RDEPEND}
        >=gnustep-base/gnustep-make-2.6.0[native-exceptions]
-       sys-devel/gcc[objc]"
+       sys-devel/gcc[objc]
+"
 
 S="${WORKDIR}/The Unarchiver/XADMaster"
 
 src_prepare() {
+       default
        # avoid jobserver warning, upstream bug:
        # https://bitbucket.org/WAHa_06x36/theunarchiver/issues/918/dont-call-make-from-makefile
-       sed -i -e 's:make:$(MAKE):g' Makefile.linux
+       sed -i -e 's:make:$(MAKE):g' Makefile.linux || die
 }
 
 src_compile() {