dev-python/pbr: fix pbr with new wheel
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 16 Apr 2020 15:33:05 +0000 (10:33 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 16 Apr 2020 15:33:53 +0000 (10:33 -0500)
Closes: https://bugs.gentoo.org/582602
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/pbr/Manifest
dev-python/pbr/pbr-4.2.0-r3.ebuild [moved from dev-python/pbr/pbr-4.2.0-r2.ebuild with 93% similarity]

index 18ab44f91828803a2309cfe564f5e28de0127268..585bf23c8a1d7303a0fa8393db199f0e69baa238 100644 (file)
@@ -2,3 +2,4 @@ DIST pbr-3.1.1.tar.gz 102665 BLAKE2B 301515d50f8550f5553a29faacb1daef589b41b8116
 DIST pbr-4.1.1.tar.gz 108683 BLAKE2B 5c0157ff14590113e7baae0bdca1ff46108a7a10d6eae8bd0a2d06bee62b4aa65eed25c900ae1b67324ac6b416641081c63a274c9694db1877b5d9073c1c04d9 SHA512 ed739901b3a2d1eafa1d4d408a39f1e5d967776571efe0913877145aaccee3114558e107a4e5704403288324c63a08cfbca07a3409bd1baafcbc33105abdf3e4
 DIST pbr-4.2.0.tar.gz 107958 BLAKE2B 716283ceb7b1a8da41e77441c7526bf8cbdb5be7c710013630d3bbddf7de0ce37f3abd063f6103f3ec27fc5c09796f6452d8117df3b533b3c7377bf6dce7d37f SHA512 d46d93333b4d0d3fd5c14e0a474ca7beceddf794a5dbcf66f810993b8d33b48602518072effcd429566f4eede2a38c4aec289df262c2c0e7ab4b82474e14f14d
 DIST pbr-5.1.1.tar.gz 113476 BLAKE2B 9e4857f13eba2e18abffa3d7c56f05eb5a5997b855f02770a807cec110e6eb4596b333b67beba2a507bb8cb55fcd3ed87a012b4a3a245b81d0a74737c010f157 SHA512 cd6f8bdc6db80841e948dbb278423556861aa681b970050a40c920dd00e32704a29cfdd28aabd4d14e0e577fff1bc816f0646a62c9450d0d85233ab5802606f1
+DIST pbr-wheel.patch 2781 BLAKE2B f36ac5bfe22e97dd93735581461f5ac79753543e0e03bcf569d95a3bfac70362c50af8bfc745e5d29ff07092e9669782ddaf3f8edd70501966c4d4682a5bfa33 SHA512 3c89eb9ea617da1d3e2eca3fadff6f5be9f55e4a258e1fbcdd221f3c0ec3cbfd13abe401bdfdb4b464baf74b8111e981f2dab4fb2839a4b52aee65212d1589f5
similarity index 93%
rename from dev-python/pbr/pbr-4.2.0-r2.ebuild
rename to dev-python/pbr/pbr-4.2.0-r3.ebuild
index 50b10709d005ac713834ae2da4510e204dacffcc..3b838aa43596733b68adb51f4b9d2337b4889414 100644 (file)
@@ -10,7 +10,8 @@ inherit distutils-r1
 
 DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
 HOMEPAGE="https://github.com/openstack-dev/pbr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+       https://github.com/openstack/pbr/commit/f14a3b2b73c6c95edbea8de799cf1df07decdf0e.patch -> ${PN}-wheel.patch"
 
 LICENSE="Apache-2.0"
 SLOT="0"
@@ -46,6 +47,8 @@ DEPEND="
        )"
 PDEPEND=""
 
+PATCHES=("${DISTDIR}/${PN}-wheel.patch")
+
 # This normally actually belongs here.
 python_prepare_all() {
        # This test passes when run within the source and doesn't represent a failure, but rather