dev-libs/nettle: add USE=asm
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 1 May 2020 13:30:33 +0000 (15:30 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 1 May 2020 13:30:33 +0000 (15:30 +0200)
Closes: https://bugs.gentoo.org/710122
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/nettle/metadata.xml
dev-libs/nettle/nettle-3.6.ebuild

index d6799109786659e6cd8830eb5f6e921304a29fc3..1762d332757499f592cd6e803f48fbf5b18a564b 100644 (file)
@@ -8,4 +8,7 @@
        <upstream>
                <remote-id type="cpe">cpe:/a:nettle_project:nettle</remote-id>
        </upstream>
+       <use>
+               <flag name="asm">Support assembly hand optimized crypto functions (i.e. faster run time)</flag>
+       </use>
 </pkgmetadata>
index 6131eaec35e8046c5539dba712e6b5ac6bc6ea67..865b190a4cbd00e590f87e7317f9b38ef3509d98 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
 LICENSE="|| ( LGPL-3 LGPL-2.1 )"
 SLOT="0/7" # subslot = libnettle soname version
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes cpu_flags_x86_sha"
+IUSE="+asm doc +gmp neon static-libs test cpu_flags_x86_aes cpu_flags_x86_sha"
 RESTRICT="!test? ( test )"
 
 DEPEND="gmp? ( >=dev-libs/gmp-6.1:0=[static-libs?,${MULTILIB_USEDEP}] )"
@@ -52,6 +52,7 @@ multilib_src_configure() {
                $(tc-is-static-only && echo --disable-shared) \
                $(use_enable cpu_flags_x86_aes x86-aesni) \
                $(use_enable cpu_flags_x86_sha x86-sha-ni) \
+               $(use_enable asm assembler)
                $(use_enable doc documentation) \
                $(use_enable gmp public-key) \
                $(use_enable neon arm-neon) \