dev-libs/darts: Use sources from Darts-clone (fork of Darts).
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sat, 28 Sep 2019 03:01:59 +0000 (03:01 +0000)
committerMike Gilbert <floppym@gentoo.org>
Sun, 29 Sep 2019 02:56:14 +0000 (22:56 -0400)
Fixes: https://bugs.gentoo.org/692950
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-libs/darts/Manifest
dev-libs/darts/darts-0.32h_pre20181117064816.ebuild [new file with mode: 0644]
dev-libs/darts/darts-9999.ebuild [new file with mode: 0644]
dev-libs/darts/metadata.xml

index 5a6424dbf0947d3a2c4774ce66820ab2a3979f9f..0b6865602030382887ae5b3457cf6852703a6fc4 100644 (file)
@@ -1 +1,2 @@
 DIST darts-0.32.tar.gz 234001 BLAKE2B e40f16e6ead25809d981c98924867903e1d0f3734682b61ad1be40a10a4212795dfdef55a0eb6f9d0f60ef7676ed27929a6812bf8f57972dcf00875e99d9917b SHA512 b9af8ce60688f5858dac2cac35a8666848dba6729f9f4364786123a1c0484e56c8b981ec04e59653afbcf20cce3b326a49243095213efb525b5669472ac7358e
+DIST darts-0.32h_pre20181117064816.tar.gz 38856 BLAKE2B db4bf7ca88ceb81dcaee4494708d3f469dfc4f1ce53aa731f291d4b7d73f2c48a9e8d97caf32fd0bdd66aaba1c9e3e2e0289a5f2fdf7f5f1f2351c3808d6a98c SHA512 092cc833fff937365117f5b780f09a1ffdd25104ab57e36f7cba25a9a6bee289c105cae997a50b61b5b542c1c34d71bddf132d0ca14d563198b57caa9af2ac22
diff --git a/dev-libs/darts/darts-0.32h_pre20181117064816.ebuild b/dev-libs/darts/darts-0.32h_pre20181117064816.ebuild
new file mode 100644 (file)
index 0000000..a379bd2
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+WANT_LIBTOOL="none"
+
+inherit autotools
+
+if [[ "${PV}" == "9999" ]]; then
+       inherit git-r3
+
+       EGIT_REPO_URI="https://github.com/s-yata/darts-clone"
+else
+       DARTS_CLONE_GIT_REVISION="e40ce4627526985a7767444b6ed6893ab6ff8983"
+fi
+
+DESCRIPTION="Darts-clone (Double-ARray Trie System) C++ library"
+# Original upstream: http://chasen.org/~taku/software/darts/
+HOMEPAGE="https://github.com/s-yata/darts-clone https://code.google.com/archive/p/darts-clone/"
+if [[ "${PV}" == "9999" ]]; then
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/s-yata/darts-clone/archive/${DARTS_CLONE_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+       S="${WORKDIR}/darts-clone-${DARTS_CLONE_GIT_REVISION}"
+fi
+
+src_prepare() {
+       default
+       eaclocal
+       eautoconf
+       eautomake
+}
+
+src_install() {
+       default
+
+       local language source_file target_file
+       for source_file in doc/*/*.md; do
+               language="${source_file#*/}"
+               language="${language%%/*}"
+               target_file="${source_file##*/}"
+               target_file="${target_file%.md}.${language}.md"
+               newdoc "${source_file}" "${target_file}"
+       done
+}
diff --git a/dev-libs/darts/darts-9999.ebuild b/dev-libs/darts/darts-9999.ebuild
new file mode 100644 (file)
index 0000000..556c583
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 2003-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+WANT_LIBTOOL="none"
+
+inherit autotools
+
+if [[ "${PV}" == "9999" ]]; then
+       inherit git-r3
+
+       EGIT_REPO_URI="https://github.com/s-yata/darts-clone"
+else
+       DARTS_CLONE_GIT_REVISION=""
+fi
+
+DESCRIPTION="Darts-clone (Double-ARray Trie System) C++ library"
+# Original upstream: http://chasen.org/~taku/software/darts/
+HOMEPAGE="https://github.com/s-yata/darts-clone https://code.google.com/archive/p/darts-clone/"
+if [[ "${PV}" == "9999" ]]; then
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/s-yata/darts-clone/archive/${DARTS_CLONE_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+       S="${WORKDIR}/darts-clone-${DARTS_CLONE_GIT_REVISION}"
+fi
+
+src_prepare() {
+       default
+       eaclocal
+       eautoconf
+       eautomake
+}
+
+src_install() {
+       default
+
+       local language source_file target_file
+       for source_file in doc/*/*.md; do
+               language="${source_file#*/}"
+               language="${language%%/*}"
+               target_file="${source_file##*/}"
+               target_file="${target_file%.md}.${language}.md"
+               newdoc "${source_file}" "${target_file}"
+       done
+}
index c921b96adf6ced372394a69a4687e96d659e0e44..bb2998c433a27301f52ddc49b777d89ff92c215e 100644 (file)
@@ -1,8 +1,11 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-       <email>cjk@gentoo.org</email>
-       <name>Cjk</name>
-</maintainer>
+       <maintainer type="project">
+               <email>cjk@gentoo.org</email>
+               <name>Cjk</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">s-yata/darts-clone</remote-id>
+       </upstream>
 </pkgmetadata>