dev-ml/ppx_custom_printf: initial import; ebuild by me
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 18:10:37 +0000 (19:10 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_custom_printf/Manifest [new file with mode: 0644]
dev-ml/ppx_custom_printf/metadata.xml [new file with mode: 0644]
dev-ml/ppx_custom_printf/ppx_custom_printf-113.24.00.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ppx_custom_printf/Manifest b/dev-ml/ppx_custom_printf/Manifest
new file mode 100644 (file)
index 0000000..97ab749
--- /dev/null
@@ -0,0 +1 @@
+DIST ppx_custom_printf-113.24.00.tar.gz 57244 SHA256 d2e4f30fe56b0e86c52bab281502b7209c026e9556c7ae1ecd646835d5338bea SHA512 f071c6f2220b518b455c9eb93ce40c6fddcbf3874354e3c7aac9f05e408b0f2ef7cb26c4b3af944b53d0946f4f80558cfa229637003070d89f4414e96505fcc8 WHIRLPOOL 2da8a90e848dec859d615680fa1bc23670c0724c16e00fc640c1dfcddb9bd5701238a06348216fb9c8663e30ba0b8cdcc8961bc94b3fb6f5e49434bdb3303954
diff --git a/dev-ml/ppx_custom_printf/metadata.xml b/dev-ml/ppx_custom_printf/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-113.24.00.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-113.24.00.ebuild
new file mode 100644 (file)
index 0000000..225be12
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+       dev-ml/ppx_core:=
+       dev-ml/ppx_driver:=
+       dev-ml/ppx_sexp_conv:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}