dev-libs/qrosspython: build 9999 with Qt5
author0xd34df00d <0xd34df00d@gmail.com>
Fri, 17 Feb 2017 04:38:59 +0000 (05:38 +0100)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 25 Feb 2017 00:38:28 +0000 (11:38 +1100)
dev-libs/qrosspython/qrosspython-9999.ebuild

index 9788aa58012067091a4d629c6ee920025cb91605..40f7f404ce492ed4c3c9020929618eab11717800 100644 (file)
@@ -1,14 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
-EGIT_REPO_URI="git://github.com/0xd34df00d/Qross.git"
 
 inherit git-r3 python-single-r1 cmake-utils
 
+EGIT_REPO_URI="git://github.com/0xd34df00d/Qross.git"
+
 DESCRIPTION="Python scripting backend for Qross"
 HOMEPAGE="https://github.com/0xd34df00d/Qross"
 
@@ -20,14 +21,16 @@ IUSE="debug"
 RDEPEND="
        ~dev-libs/qrosscore-${PV}
        dev-python/sip
-       dev-qt/qtcore:4
-       dev-qt/qtgui:4
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
        ${PYTHON_DEPS}
 "
 DEPEND="${RDEPEND}
-       dev-qt/qttest:4
+       dev-qt/qttest:5
 "
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 CMAKE_USE_DIR="${S}/src/bindings/python/qrosspython"
+
+mycmakeargs=( -DUSE_QT5=ON )