dev-util/bless: Bump to 0.6.2
authorMike Auty <ikelos@gentoo.org>
Mon, 16 Sep 2019 22:21:24 +0000 (23:21 +0100)
committerMike Auty <ikelos@gentoo.org>
Mon, 16 Sep 2019 22:46:20 +0000 (23:46 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Mike Auty <ikelos@gentoo.org>
dev-util/bless/Manifest
dev-util/bless/bless-0.6.2.ebuild [new file with mode: 0644]

index 16cb7bddd173eb80c35430a0232678c4698ca320..52ba93ae47f62119afe5dcc5b3a9ddcdbbd7042b 100644 (file)
@@ -1 +1,2 @@
 DIST bless-0.6.0.tar.gz 745694 BLAKE2B eb23edf3fd9c45b9848810ff022a7e9b7d760c22444426bbbaf63d69ee45754d085eb105c4951c0d57fce7b284c6b0a8fb9b7e061219a55d109c9ef844b61c35 SHA512 69d2279b64503b97c8a67991c2a7a527d872835e3acfad7eafa8d87e376d2cecf3fa27de9e12726680a8f3c8ac92b888a4895a1f342c4beeaceef9e1f3ededdb
+DIST v0.6.2.tar.gz 514695 BLAKE2B 2c9681e03992d42b20d0073e9107e5bd83d6f1699235b49fb6cf14fb5f9bc87e682e96b4f8bab2b45a3211515a8990e72b80922a62198c7ad603aeb5f3d3c406 SHA512 3fef715ed138323af50437ef8cda3d9f53987498042f1b4df2d9ce23f00dade68147cbdf28b85aed8b9c594fb5c43839c9dedbc14a994ad609fd4cedd89bfcf5
diff --git a/dev-util/bless/bless-0.6.2.ebuild b/dev-util/bless/bless-0.6.2.ebuild
new file mode 100644 (file)
index 0000000..d63bb96
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2 mono-env
+
+DESCRIPTION="GTK# Hex Editor"
+HOMEPAGE="https://github.com/afrantzis/Bless/"
+SRC_URI="https://github.com/afrantzis/${PN}/archive/v${PV}.tar.gz"
+# EGIT_REPO_URI="https://github.com/afrantzis/bless/"
+# EGIT_COMMIT="v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+       >=dev-lang/mono-1.1.14
+       >=dev-dotnet/gtk-sharp-2.12.21
+"
+DEPEND="${RDEPEND}
+       app-text/rarian
+       >=sys-devel/gettext-0.15
+       virtual/pkgconfig
+"
+
+# See bug 278162
+# Waiting on nunit ebuild entering the tree
+RESTRICT="test"
+
+pkg_setup() {
+       mono-env_pkg_setup
+}
+
+src_prepare() {
+       eautoreconf
+       # The autoreconf expects INSTALL to have been copied over by autoconf
+       touch "${S}/INSTALL"
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --enable-unix-specific \
+               $(use_enable debug)
+}
+
+src_install() {
+       default
+
+       mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}"
+}