dev-python/mypy: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sat, 10 Mar 2018 14:37:22 +0000 (15:37 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 10 Mar 2018 14:53:03 +0000 (15:53 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-python/mypy/Manifest
dev-python/mypy/mypy-0.4.3.ebuild [deleted file]
dev-python/mypy/mypy-0.4.4.ebuild [deleted file]

index 82c1719b3f415abcecb8f6cc94c177d0f4ba3230..67e233cc97d02a4b8a1aedfcda348f6f4e10e862 100644 (file)
@@ -1,3 +1 @@
-DIST mypy-0.4.3.tar.gz 714118 BLAKE2B 2220545af1c85391206ff420d910dbfb6cd82d8fb5cb3cc89f09aef5d3868a90ba76f2fe370f5853dad2ab92754e7ac622c892485604e12fb407b261a073b842 SHA512 2185eccb6fa783168879acfc316da0c879fca0b04e6a21bbd47a456014281d634711d9f3e25fa3a64a0b7819b54f0bb87f8bede7452147fd3bab8bca4859f5f0
-DIST mypy-0.4.4.tar.gz 757353 BLAKE2B 26a04bb584adc5456f730d19e5eaa68e556c401da8290b2c802d115722a5ff3d29fb87d6f436979d272fde021c8655ae8c1af011f2c798a9382298f642718826 SHA512 7a5cb8dae4d28cb7803b56ce17e379dd5f1f953663af6a5c2510e3183028f06a8b3722b94843a782e01e4a65b3f5ae48ff002ad85bfb85cad05abb181fc60e47
 DIST mypy-0.4.5.tar.gz 779940 BLAKE2B 5242d57a5c0baf1f32e018e671c5eb21aee3ccbc4e7abfc578562c32c2be425848dcb7cd9a7d726268527337bb11f3dae88f1d79b5db87d1db857927ebad4a45 SHA512 e0bd4cb1080f2a4c0f2c4f9ebbe22d05b8dabb374396e7d91c645724b5d67084fd005e181847fccc45c9c51f3280233185fa6bf08dc24c2d4f6e482197246fa7
diff --git a/dev-python/mypy/mypy-0.4.3.ebuild b/dev-python/mypy/mypy-0.4.3.ebuild
deleted file mode 100644 (file)
index c85d92e..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_4 python3_5 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="http://www.mypy-lang.org/"
-SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
-       test? ( dev-python/flake8[${PYTHON_USEDEP}] )
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="$(python_gen_cond_dep '!dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       local PYTHONPATH="$(pwd)"
-
-       "${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/mypy/mypy-0.4.4.ebuild b/dev-python/mypy/mypy-0.4.4.ebuild
deleted file mode 100644 (file)
index c85d92e..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_4 python3_5 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="http://www.mypy-lang.org/"
-SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
-       test? ( dev-python/flake8[${PYTHON_USEDEP}] )
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="$(python_gen_cond_dep '!dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       local PYTHONPATH="$(pwd)"
-
-       "${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-
-       distutils-r1_python_install_all
-}