dev-python/pecan: use python_gen_cond_dep for py27 deps
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 23 Aug 2019 16:42:08 +0000 (11:42 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 23 Aug 2019 16:42:31 +0000 (11:42 -0500)
Fixes: https://bugs.gentoo.org/692448

Package-Manager: Portage-2.3.69, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/pecan/pecan-1.3.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pecan/pecan-1.3.3-r1.ebuild b/dev-python/pecan/pecan-1.3.3-r1.ebuild
new file mode 100644 (file)
index 0000000..e8f8563
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework,  lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       virtual/python-singledispatch[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)
+       >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+       >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+       >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"