dev-python/pyproj: Drop -fno-strict-aliasing workaround
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 18:54:01 +0000 (19:54 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 18:54:01 +0000 (19:54 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pyproj/pyproj-2.4.2.ebuild

index 5e1362ac22f3b48b7f3297a02d14ccd57568d1b0..9cf1b1cb8b08876c0e712486ce00b46aa609308e 100644 (file)
@@ -6,7 +6,7 @@ EAPI=7
 # Python < 3.6 requires https://pypi.org/project/aenum/
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit distutils-r1 flag-o-matic
+inherit distutils-r1
 
 DESCRIPTION="Python interface to the PROJ library"
 HOMEPAGE="https://github.com/jswhit/pyproj"
@@ -32,11 +32,6 @@ PATCHES=( "${FILESDIR}"/${P}-conftest.patch )
 distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
 distutils_enable_tests pytest
 
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-       append-cflags -fno-strict-aliasing
-}
-
 python_test() {
        PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
 }