dev-ros/tf2_sensor_msgs: Bump to 0.5.16.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 15 Jul 2017 16:26:30 +0000 (18:26 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 16 Jul 2017 12:17:00 +0000 (14:17 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ros/tf2_sensor_msgs/Manifest
dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.16.ebuild [new file with mode: 0644]

index 5877951f5252f00f2ff3e94b353483854d0c09f1..0ab574dea08bc3c2d2da54f6bf12ef1a7c98bc6a 100644 (file)
@@ -1 +1,2 @@
 DIST geometry2-0.5.15.tar.gz 147275 SHA256 fba4c223e85923060d76f1113b346207b2d36cda0e2c3393ec96ff99ba918dbe SHA512 10a750948157904c0812aaae85e21eaf5c85dfef3770d418fd0c592a9179cef9fc2082ecc125be0fd0032e705dfb678d45930d3aa2cd0986a71c2e0a7307722c WHIRLPOOL d982cae97a0d3de2320a9a4318f84aef1403d7f59c1dfe88fd274a517d4e5b5263434cffe16cf2a346ddccecb4e3263445c3008feb9ec1efb053361dc51286e1
+DIST geometry2-0.5.16.tar.gz 154351 SHA256 61001913ea7568a513171f57a09f02905918cee0b558baa27f7439fbb79700cb SHA512 11909db98af78bbdef8d1a7dc5f20d3ff3cfcb0afc0e1d53b97a1ffe99aecea911f09364593eb232d7514a4caa192141404d892a33fc7ea9f5ce924ecf99fc51 WHIRLPOOL 43fb2d7b53fa3a134c3a2881d8985a1cc5f34983aac5031647791149301063e1679f69a08ec0ac983b708b25fda5871d0477c237b91864987115fcb2063a622f
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.16.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.16.ebuild
new file mode 100644 (file)
index 0000000..9d28f70
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/tf2_ros[${PYTHON_USEDEP}]
+       dev-ros/tf2
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+       dev-ros/cmake_modules"