net-misc/streamlink: bump to 1.3.1
authorMart Raudsepp <leio@gentoo.org>
Sat, 22 Feb 2020 12:19:31 +0000 (14:19 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 22 Feb 2020 12:19:31 +0000 (14:19 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-misc/streamlink/Manifest
net-misc/streamlink/streamlink-1.3.1.ebuild [new file with mode: 0644]

index 302919b4d0813ade84e9a8473d9fb0699b9ec693..dfe3771aed8612d1ad0b07869fd7129de655b498 100644 (file)
@@ -1 +1,2 @@
 DIST streamlink-1.3.0.tar.gz 694190 BLAKE2B cd262290cd81f1954567e217eaf9568c00180ee7f6955c8227b7067488d685385fe8b4b3bcd6004e7e8f7f66236696a48e744cb24c4d00f2111f00633ffeb1bf SHA512 5a114e0b1e617b2a41f8fe00f9bd6846843dd7643b4283d2fe30ea869cc9d6f495458b0ddb97955a87b7ad64e5628343262af5068b8a7a19d0d84a32020b3365
+DIST streamlink-1.3.1.tar.gz 695736 BLAKE2B 377fdfb6a90b2e680697dda57b4237a14b63df1e33af5fcbf8333ebd3bc85f877e0e3c4698ab965d766560234cc0ddb7399c8b43eac1b3bbbc4984bfd2ed2194 SHA512 d6c299c6ea444d5b5956a752be8a5c192ca2aae25087db4045035c53fa078396b1bf89203cd55a82630c33492117323892caa5cf27c9dc9ea4b64602dbfdd87c
diff --git a/net-misc/streamlink/streamlink-1.3.1.ebuild b/net-misc/streamlink/streamlink-1.3.1.ebuild
new file mode 100644 (file)
index 0000000..28994a6
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+       GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 $GIT_ECLASS
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+       SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
+DEPEND="
+       $(python_gen_cond_dep '
+               virtual/python-futures[${PYTHON_MULTI_USEDEP}]
+               virtual/python-singledispatch[${PYTHON_MULTI_USEDEP}]
+               >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/urllib3-1.23[${PYTHON_MULTI_USEDEP}]
+               dev-python/isodate[${PYTHON_MULTI_USEDEP}]
+               dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
+               dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
+       ')
+"
+RDEPEND="${DEPEND}
+       media-video/rtmpdump
+       virtual/ffmpeg
+"
+BDEPEND="
+       $(python_gen_cond_dep '
+               doc? (
+                       dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+                       dev-python/docutils[${PYTHON_MULTI_USEDEP}]
+                       dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
+               )
+               test? (
+                       dev-python/mock[${PYTHON_MULTI_USEDEP}]
+                       dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
+                       dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+                       dev-python/freezegun[${PYTHON_MULTI_USEDEP}]
+               )
+       ')"
+
+python_configure_all() {
+       # Avoid iso-639, iso3166 dependencies since we use pycountry.
+       export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+       use doc && emake -C docs html man
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       if use doc; then
+               local HTML_DOCS=( docs/_build/html/. )
+               doman docs/_build/man/*
+       fi
+       distutils-r1_python_install_all
+}