app-text/cwtext: Bump to EAPI=7
authorThomas Beierlein <tomjbe@gentoo.org>
Thu, 7 Nov 2019 06:19:55 +0000 (07:19 +0100)
committerThomas Beierlein <tomjbe@gentoo.org>
Thu, 7 Nov 2019 06:19:55 +0000 (07:19 +0100)
Closes: https://bugs.gentoo.org/697370
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
app-text/cwtext/cwtext-0.96-r1.ebuild [new file with mode: 0644]

diff --git a/app-text/cwtext/cwtext-0.96-r1.ebuild b/app-text/cwtext/cwtext-0.96-r1.ebuild
new file mode 100644 (file)
index 0000000..8ee1945
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Text to Morse Code converter"
+HOMEPAGE="http://cwtext.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.94-asneeded.patch )
+DOCS=( Changes README TODO )
+
+src_prepare() {
+       eapply -p0 "${PATCHES}"
+       # change install directory to ${S}
+       sed -i -e "/^PREFIX/ s:=.*:=\"${S}\":" makefile || \
+               die "sed makefile failed"
+
+       eapply_user
+       tc-export CC
+}
+
+src_install() {
+       einstalldocs
+       dobin cwtext cwpcm cwmm
+}