app-backup/bacula: Fix for broken libressl support
authorThomas Beierlein <tomjbe@gentoo.org>
Wed, 25 Apr 2018 15:33:56 +0000 (17:33 +0200)
committerThomas Beierlein <tomjbe@gentoo.org>
Wed, 25 Apr 2018 15:35:05 +0000 (17:35 +0200)
Backport of patches from FreeBSD bugtracker
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223994
to fix broken support for libressl.

Bug: https://bugs.gentoo.org/641492
Package-Manager: Portage-2.3.31, Repoman-2.3.9

app-backup/bacula/bacula-9.0.6-r3.ebuild [new file with mode: 0644]
app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl.patch [new file with mode: 0644]

diff --git a/app-backup/bacula/bacula-9.0.6-r3.ebuild b/app-backup/bacula/bacula-9.0.6-r3.ebuild
new file mode 100644 (file)
index 0000000..f30acaa
--- /dev/null
@@ -0,0 +1,430 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit qmake-utils desktop systemd user libtool
+
+MY_PV=${PV/_beta/-b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+SRC_URI="mirror://sourceforge/bacula/${MY_P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl bacula-clientonly bacula-nodir bacula-nosd examples ipv6 libressl logwatch mysql postgres qt5 readline +sqlite ssl static tcpd vim-syntax X"
+
+DEPEND="
+       dev-libs/gmp:0
+       !bacula-clientonly? (
+               postgres? ( dev-db/postgresql:=[threads] )
+               mysql? ( virtual/mysql )
+               sqlite? ( dev-db/sqlite:3 )
+               !bacula-nodir? ( virtual/mta )
+       )
+       qt5? (
+               dev-qt/qtsvg:5
+               x11-libs/qwt:6
+       )
+       logwatch? ( sys-apps/logwatch )
+       tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+       readline? ( sys-libs/readline:0 )
+       static? (
+               acl? ( virtual/acl[static-libs] )
+               sys-libs/zlib[static-libs]
+               dev-libs/lzo[static-libs]
+               sys-libs/ncurses:=[static-libs]
+               ssl? (
+                       !libressl? ( dev-libs/openssl:0=[static-libs] )
+                       libressl? ( dev-libs/libressl:0=[static-libs] )
+               )
+       )
+       !static? (
+               acl? ( virtual/acl )
+               sys-libs/zlib
+               dev-libs/lzo
+               sys-libs/ncurses:=
+               ssl? (
+                       !libressl? ( dev-libs/openssl:0= )
+                       libressl? ( dev-libs/libressl:0= )
+               )
+       )"
+RDEPEND="${DEPEND}
+       !bacula-clientonly? (
+               !bacula-nosd? (
+                       sys-block/mtx
+                       app-arch/mt-st
+               )
+       )
+       vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+REQUIRED_USE="!bacula-clientonly? ( ^^ ( mysql postgres sqlite ) )
+                               static? ( bacula-clientonly )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+       #XOR and !bacula-clientonly controlled by REQUIRED_USE
+       use mysql && export mydbtype="mysql"
+       use postgres && export mydbtype="postgresql"
+       use sqlite && export mydbtype="sqlite3"
+
+       # create the daemon group and user
+       if [ -z "$(egetent group bacula 2>/dev/null)" ]; then
+               enewgroup bacula
+               einfo
+               einfo "The group 'bacula' has been created. Any users you add to this"
+               einfo "group have access to files created by the daemons."
+               einfo
+       fi
+
+       if use bacula-clientonly && use static && use qt5; then
+               ewarn
+               ewarn "Building statically linked 'bat' is not supported. Ignorig 'qt5' useflag."
+               ewarn
+       fi
+
+       if ! use bacula-clientonly; then
+               if [ -z "$(egetent passwd bacula 2>/dev/null)" ]; then
+                       enewuser bacula -1 -1 /var/lib/bacula bacula,disk,tape,cdrom,cdrw
+                       einfo
+                       einfo "The user 'bacula' has been created.  Please see the bacula manual"
+                       einfo "for information about running bacula as a non-root user."
+                       einfo
+               fi
+       fi
+}
+
+src_prepare() {
+       # adjusts default configuration files for several binaries
+       # to /etc/bacula/<config> instead of ./<config>
+       pushd src >&/dev/null || die
+       for f in console/console.c dird/dird.c filed/filed.c \
+               stored/bcopy.c stored/bextract.c stored/bls.c \
+               stored/bscan.c stored/btape.c stored/stored.c \
+               qt-console/main.cpp; do
+               sed -i -e 's|^\(#define CONFIG_FILE "\)|\1/etc/bacula/|g' "${f}" \
+                       || die "sed on ${f} failed"
+       done
+       popd >&/dev/null || die
+
+       # bug 466688 drop deprecated categories from Desktop file
+       sed -i -e 's/Application;//' scripts/bat.desktop.in || die
+
+       # bug 466690 Use CXXFLAGS instead of CFLAGS
+       sed -i -e 's/@CFLAGS@/@CXXFLAGS@/' autoconf/Make.common.in || die
+
+       # drop automatic install of unneeded documentation (for bug 356499)
+       eapply -p0 "${FILESDIR}"/7.2.0/${PN}-7.2.0-doc.patch
+
+       # bug #310087
+       eapply "${FILESDIR}"/5.2.3/${PN}-5.2.3-as-needed.patch
+
+       # bug #311161
+       eapply -p0 "${FILESDIR}"/9.0.2/${PN}-9.0.2-lib-search-path.patch
+
+       # bat needs to respect LDFLAGS and CFLAGS
+       eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-bat-pro.patch
+
+       # bug #328701
+       eapply -p0 "${FILESDIR}"/5.2.3/${PN}-5.2.3-openssl-1.patch
+
+       eapply -p0 "${FILESDIR}"/9.0.2/${PN}-9.0.2-fix-static.patch
+
+       # fix soname in libbaccat.so bug #602952
+       eapply -p0 "${FILESDIR}/bacula-fix-sonames.patch"
+
+       # do not strip binaries
+       sed -i -e "s/strip /# strip /" src/filed/Makefile.in || die
+       sed -i -e "s/strip /# strip /" src/console/Makefile.in || die
+
+       # fix file not found error during make depend
+       eapply -p0 "${FILESDIR}"/7.0.2/${PN}-7.0.2-depend.patch
+
+       # fix missing QtGlobal include in src/qt-console/pages.h for Qt5
+       eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-fix-pages-h-qt-includes.patch
+       eapply_user
+
+       # Fix systemd unit files:
+       # bug 497748
+       sed -i -e '/Requires/d' platforms/systemd/*.service.in || die
+       sed -i -e '/StandardOutput/d' platforms/systemd/*.service.in || die
+       # bug 504370
+       sed -i -e '/Alias=bacula-dir/d' platforms/systemd/bacula-dir.service.in || die
+       # bug 584442 and 504368
+       sed -i -e 's/@dir_user@/root/g' platforms/systemd/bacula-dir.service.in || die
+
+       # build 'bat' for Qt5
+       export QMAKE="$(qt5_get_bindir)"/qmake
+
+       # adapt to >=Qt-5.9 (see bug #644566)
+       # qmake needs an existing target file to generate install instructions
+       sed -i -e 's#bins.files = bat#bins.files = .libs/bat#g' \
+               src/qt-console/bat.pro.in || die
+       mkdir src/qt-console/.libs || die
+       touch src/qt-console/.libs/bat || die
+       chmod 755 src/qt-console/.libs/bat || die
+
+       # fix wrong handling of libressl version
+       eapply -p0 "${FILESDIR}"/9.0.6/${PN}-9.0.6-libressl.patch
+
+       # fix bundled libtool (bug 466696)
+       # But first move directory with M4 macros out of the way.
+       # It is only needed by autoconf and gives errors during elibtoolize.
+       mv autoconf/libtool autoconf/libtool1 || die
+       elibtoolize
+}
+
+src_configure() {
+       local myconf=''
+
+       if use bacula-clientonly; then
+               myconf="${myconf} \
+                       $(use_enable bacula-clientonly client-only) \
+                       $(use_enable !static libtool) \
+                       $(use_enable static static-cons) \
+                       $(use_enable static static-fd)"
+       else
+               myconf="${myconf} \
+                       $(use_enable !bacula-nodir build-dird) \
+                       $(use_enable !bacula-nosd build-stored)"
+               # bug #311099
+               # database support needed by dir-only *and* sd-only
+               # build as well (for building bscan, btape, etc.)
+               myconf="${myconf}
+                       --with-${mydbtype}"
+               if use mysql; then
+                   myconf="${myconf} \
+                       --disable-batch-insert"
+               else
+                   myconf="${myconf} \
+                       --enable-batch-insert"
+               fi
+       fi
+
+       # do not build bat if 'static' clientonly
+       if ! use bacula-clientonly || ! use static; then
+               myconf="${myconf} \
+                       $(use_enable qt5 bat)"
+       fi
+
+       myconf="${myconf} \
+               $(use_with X x) \
+               $(use_enable !readline conio) \
+               $(use_enable readline) \
+               $(use_with readline readline /usr) \
+               $(use_with ssl openssl) \
+               $(use_enable ipv6) \
+               $(use_enable acl) \
+               $(use_with tcpd tcp-wrappers)"
+
+       econf \
+               --libdir=/usr/$(get_libdir) \
+               --docdir=/usr/share/doc/${PF} \
+               --htmldir=/usr/share/doc/${PF}/html \
+               --with-pid-dir=/var/run \
+               --sysconfdir=/etc/bacula \
+               --with-subsys-dir=/var/lock/subsys \
+               --with-working-dir=/var/lib/bacula \
+               --with-logdir=/var/lib/bacula \
+               --with-scriptdir=/usr/libexec/bacula \
+               --with-systemd=$(systemd_get_systemunitdir) \
+               --with-dir-user=bacula \
+               --with-dir-group=bacula \
+               --with-sd-user=root \
+               --with-sd-group=bacula \
+               --with-fd-user=root \
+               --with-fd-group=bacula \
+               --enable-smartalloc \
+               --disable-afs \
+               --host=${CHOST} \
+               ${myconf}
+}
+
+src_compile() {
+       # Make build log verbose (bug #447806)
+       emake NO_ECHO=""
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       doicon scripts/bacula.png
+
+       # install bat icon and desktop file when enabled
+       # (for some reason ./configure doesn't pick this up)
+       if use qt5 && ! use static ; then
+               doicon src/qt-console/images/bat_icon.png
+               domenu scripts/bat.desktop
+       fi
+
+       # remove some scripts we don't need at all
+       rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
+
+       # rename statically linked apps
+       if use bacula-clientonly && use static ; then
+               pushd "${D}"/usr/sbin || die
+               mv static-bacula-fd bacula-fd || die
+               mv static-bconsole bconsole || die
+               popd || die
+       fi
+
+       # extra files which 'make install' doesn't cover
+       if ! use bacula-clientonly; then
+           # the database update scripts
+               diropts -m0750
+               insinto /usr/libexec/bacula/updatedb
+               insopts -m0754
+               doins "${S}"/updatedb/*
+               fperms 0640 /usr/libexec/bacula/updatedb/README
+
+               # the logrotate configuration
+               # (now unconditional wrt bug #258187)
+               diropts -m0755
+               insinto /etc/logrotate.d
+               insopts -m0644
+               newins "${S}"/scripts/logrotate bacula
+
+               # the logwatch scripts
+               if use logwatch; then
+                       diropts -m0750
+                       dodir /usr/share/logwatch/scripts/services
+                       dodir /usr/share/logwatch/scripts/shared
+                       dodir /etc/logwatch/conf/logfiles
+                       dodir /etc/logwatch/conf/services
+                       pushd "${S}"/scripts/logwatch >&/dev/null || die
+                       emake DESTDIR="${D}" install
+                       popd >&/dev/null || die
+               fi
+       fi
+
+       if ! use qt5; then
+               rm -vf "${D}"/usr/share/man/man1/bat.1*
+       fi
+       rm -vf "${D}"/usr/share/man/man1/bacula-tray-monitor.1*
+       if use bacula-clientonly || use bacula-nodir; then
+               rm -vf "${D}"/usr/share/man/man8/bacula-dir.8*
+               rm -vf "${D}"/usr/share/man/man8/dbcheck.8*
+               rm -vf "${D}"/usr/share/man/man1/bsmtp.1*
+               rm -vf "${D}"/usr/libexec/bacula/create_*_database
+               rm -vf "${D}"/usr/libexec/bacula/drop_*_database
+               rm -vf "${D}"/usr/libexec/bacula/make_*_tables
+               rm -vf "${D}"/usr/libexec/bacula/update_*_tables
+               rm -vf "${D}"/usr/libexec/bacula/drop_*_tables
+               rm -vf "${D}"/usr/libexec/bacula/grant_*_privileges
+               rm -vf "${D}"/usr/libexec/bacula/*_catalog_backup
+       fi
+       if use bacula-clientonly || use bacula-nosd; then
+               rm -vf "${D}"/usr/share/man/man8/bacula-sd.8*
+               rm -vf "${D}"/usr/share/man/man8/bcopy.8*
+               rm -vf "${D}"/usr/share/man/man8/bextract.8*
+               rm -vf "${D}"/usr/share/man/man8/bls.8*
+               rm -vf "${D}"/usr/share/man/man8/bscan.8*
+               rm -vf "${D}"/usr/share/man/man8/btape.8*
+               rm -vf "${D}"/usr/libexec/bacula/disk-changer
+               rm -vf "${D}"/usr/libexec/bacula/mtx-changer
+               rm -vf "${D}"/usr/libexec/bacula/dvd-handler
+       fi
+
+       # documentation
+       dodoc ChangeLog ReleaseNotes SUPPORT
+
+       # install examples (bug #457504)
+       if use examples; then
+               docinto examples/
+               dodoc -r examples/*
+       fi
+
+       # vim-files
+       if use vim-syntax; then
+               insinto /usr/share/vim/vimfiles/syntax
+               doins scripts/bacula.vim
+               insinto /usr/share/vim/vimfiles/ftdetect
+               newins scripts/filetype.vim bacula_ft.vim
+       fi
+
+       # setup init scripts
+       myscripts="bacula-fd"
+       if ! use bacula-clientonly; then
+               if ! use bacula-nodir; then
+                       myscripts="${myscripts} bacula-dir"
+               fi
+               if ! use bacula-nosd; then
+                       myscripts="${myscripts} bacula-sd"
+               fi
+       fi
+       for script in ${myscripts}; do
+               # copy over init script and config to a temporary location
+               # so we can modify them as needed
+               cp "${FILESDIR}/${script}".confd "${T}/${script}".confd || die "failed to copy ${script}.confd"
+               cp "${FILESDIR}/newscripts/${script}".initd "${T}/${script}".initd || die "failed to copy ${script}.initd"
+
+               # now set the database dependancy for the director init script
+               case "${script}" in
+                       bacula-dir)
+                               case "${mydbtype}" in
+                                       sqlite3)
+                                               # sqlite databases don't have a daemon
+                                               sed -i -e 's/need "%database%"/:/g' "${T}/${script}".initd || die
+                                               ;;
+                                       *)
+                                               # all other databases have daemons
+                                               sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".initd || die
+                                               ;;
+                               esac
+                               ;;
+                       *)
+                               ;;
+               esac
+
+               # install init script and config
+               newinitd "${T}/${script}".initd "${script}"
+               newconfd "${T}/${script}".confd "${script}"
+       done
+
+       systemd_dounit "${S}"/platforms/systemd/bacula-{dir,fd,sd}.service
+
+       # make sure the working directory exists
+       diropts -m0750
+       keepdir /var/lib/bacula
+
+       # make sure bacula group can execute bacula libexec scripts
+       fowners -R root:bacula /usr/libexec/bacula
+}
+
+pkg_postinst() {
+       if use bacula-clientonly; then
+               fowners root:bacula /var/lib/bacula
+       else
+               fowners bacula:bacula /var/lib/bacula
+       fi
+
+       if ! use bacula-clientonly && ! use bacula-nodir; then
+               einfo
+               einfo "If this is a new install, you must create the ${mydbtype} databases with:"
+               einfo "  /usr/libexec/bacula/create_${mydbtype}_database"
+               einfo "  /usr/libexec/bacula/make_${mydbtype}_tables"
+               einfo "  /usr/libexec/bacula/grant_${mydbtype}_privileges"
+               einfo
+
+               ewarn "ATTENTION!"
+               ewarn "The format of the database may have changed."
+               ewarn "If you just upgraded from a version below 9.0.0 you must run"
+               ewarn "'update_bacula_tables' now."
+               ewarn "Make sure to have a backup of your catalog before."
+               ewarn
+       fi
+
+       if use sqlite; then
+               einfo
+               einfo "Be aware that Bacula does not officially support SQLite database anymore."
+               einfo "Best use it only for a client-only installation. See Bug #445540."
+               einfo
+       fi
+
+       einfo "Please note that 'bconsole' will always be installed. To compile 'bat'"
+       einfo "you have to enable 'USE=qt5'."
+       einfo
+}
diff --git a/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl.patch b/app-backup/bacula/files/9.0.6/bacula-9.0.6-libressl.patch
new file mode 100644 (file)
index 0000000..3df4285
--- /dev/null
@@ -0,0 +1,62 @@
+--- src/lib/crypto.c.orig       2018-02-02 15:34:39.420489000 -0600
++++ src/lib/crypto.c    2018-02-02 15:35:44.000524000 -0600
+@@ -195,7 +195,7 @@
+ IMPLEMENT_ASN1_FUNCTIONS(SignatureData)
+ IMPLEMENT_ASN1_FUNCTIONS(CryptoData)
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER) )
+ DEFINE_STACK_OF(SignerInfo);
+ DEFINE_STACK_OF(RecipientInfo);
+ #else
+--- src/lib/openssl-compat.h.orig       2018-02-02 15:26:04.182557000 -0600
++++ src/lib/openssl-compat.h    2018-02-02 15:27:50.229100000 -0600
+@@ -1,7 +1,7 @@
+ #ifndef __OPENSSL_COPMAT__H__
+ #define __OPENSSL_COPMAT__H__
+
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) )
+ static inline int EVP_PKEY_up_ref(EVP_PKEY *pkey)
+ {
+        CRYPTO_add(&pkey->references, 1, CRYPTO_LOCK_EVP_PKEY);
+--- src/lib/openssl.c.orig     2018-02-16 08:36:24.092583000 -0600
++++ src/lib/openssl.c  2018-02-16 08:37:23.795454000 -0600
+@@ -69,7 +69,7 @@
+    }
+ }
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) )
+ /* Array of mutexes for use with OpenSSL static locking */
+ static pthread_mutex_t *mutexes;
+@@ -263,7 +263,7 @@
+ {
+    int stat = 0;
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) )
+    if ((stat = openssl_init_threads()) != 0) {
+       berrno be;
+       Jmsg1(NULL, M_ABORT, 0,
+@@ -310,7 +310,7 @@
+       Jmsg0(NULL, M_ERROR, 0, _("Failed to save OpenSSL PRNG\n"));
+    }
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) )
+    openssl_cleanup_threads();
+    /* Free libssl and libcrypto error strings */
+--- src/lib/tls.c.orig 2017-11-21 18:37:16.000000000 +0100
++++ src/lib/tls.c      2018-04-16 20:00:54.082000000 +0200
+@@ -116,7 +116,7 @@
+    ctx = (TLS_CONTEXT *)malloc(sizeof(TLS_CONTEXT));
+    /* Allocate our OpenSSL TLS Context */
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
++#if ( (OPENSSL_VERSION_NUMBER >= 0x10100000L) || defined(LIBRESSL_VERSION_NUMBER) )
+    /* Allows SSLv3, TLSv1, TLSv1.1 and TLSv1.2 protocols */
+    ctx->openssl = SSL_CTX_new(TLS_method());