dev-libs/gost-engine: Update dependencies for test
authorCraig Andrews <candrews@gentoo.org>
Tue, 30 Oct 2018 13:55:50 +0000 (09:55 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 30 Oct 2018 13:56:30 +0000 (09:56 -0400)
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-libs/gost-engine/gost-engine-9999.ebuild

index 782e02fbd454ab6183f4a6a00d988021b6b62c25..424b0bc09f5644a274fc17d095a5fc5b1d87a824 100644 (file)
@@ -7,11 +7,17 @@ inherit cmake-utils
 
 DESCRIPTION="A reference implementation of the Russian GOST crypto algorithms for OpenSSL"
 HOMEPAGE="https://github.com/gost-engine/engine"
-
+IUSE="test"
+RESTRICT="!test? ( test )"
 SLOT="0/${PV}"
 
-DEPEND=">=dev-libs/openssl-1.1:0="
-RDEPEND="${DEPEND}"
+COMMON_DEPEND=">=dev-libs/openssl-1.1:0="
+DEPEND="${COMMON_DEPEND}
+       virtual/pkgconfig
+       test? (
+               dev-lang/perl
+       )"
+RDEPEND="${COMMON_DEPEND}"
 
 LICENSE="openssl"