dev-util/valgrind: version bump to 3.16.0
authorAnthony G. Basile <blueness@gentoo.org>
Thu, 28 May 2020 21:49:16 +0000 (17:49 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Thu, 28 May 2020 21:49:34 +0000 (17:49 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
dev-util/valgrind/Manifest
dev-util/valgrind/valgrind-3.16.0.ebuild [new file with mode: 0644]

index dcf5af4b3c0f857aeebe369771f21453cb1f3591..f6762bcaa828bb8d14eedd1ac3484e1714c98e42 100644 (file)
@@ -1,2 +1,3 @@
 DIST valgrind-3.14.0.tar.bz2 16602858 BLAKE2B 00d601593388180cc874cf2f0c78e79f705f145e45ea82996117cb91ba881e7888ef241fb7e45927f82f99666d76ed35cb5d451e9a3ef123c04a0dff233b2269 SHA512 68e548c42df31dc2b883a403e0faff7480c49b3054841870f5d2f742141ba199eca5d83c96bbf283115f0633f2bdb0860161d422f98e3ec720ec65760d250f97
 DIST valgrind-3.15.0.tar.bz2 20241437 BLAKE2B a1bd46d46b3cd9f963773d011e7c74bf5e09e59be13afe38229a3c66a89eeb416498faed67d6ec21489b630b55ac73cc212e17ba515884f8b6374849a60e3720 SHA512 5695d1355226fb63b0c80809ed43bb077b6eed4d427792d9d7ed944c38b557a84fe3c783517b921e32f161228e10e4625bea0550faa4685872bb4454450cfa7f
+DIST valgrind-3.16.0.tar.bz2 16267317 BLAKE2B 4ab7a248bc46a772a03fecdab4658b059e65dc328f422f51d23d116d658b8fcfe1dc4b3b26b43ca7bd824169b169506f67cd14a1db2b767b5b5a34c949687d25 SHA512 6c82a0121e0ffde79f84943ea0f5791159ad3e37a490c1a18ff23f41cd4de62b62110e9c4d48b95b06d542f2a6d638492ecaeba9fed48f7e909e959aa4b4856d
diff --git a/dev-util/valgrind/valgrind-3.16.0.ebuild b/dev-util/valgrind/valgrind-3.16.0.ebuild
new file mode 100644 (file)
index 0000000..33873a0
--- /dev/null
@@ -0,0 +1,120 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mpi"
+
+if [[ ${PV} == "9999" ]]; then
+       EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
+       KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+fi
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       # Correct hard coded doc location
+       sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+       # Don't force multiarch stuff on OSX, bug #306467
+       sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+       # Respect CFLAGS, LDFLAGS
+       eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+
+       eapply "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+
+       if [[ ${CHOST} == *-solaris* ]] ; then
+               # upstream doesn't support this, but we don't build with
+               # Sun/Oracle ld, we have a GNU toolchain, so get some things
+               # working the Linux/GNU way
+               find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+                       sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+               cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+       fi
+
+       # Allow users to test their own patches
+       eapply_user
+
+       # Regenerate autotools files
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=()
+
+       # Respect ar, bug #468114
+       tc-export AR
+
+       # -fomit-frame-pointer  "Assembler messages: Error: junk `8' after expression"
+       #                       while compiling insn_sse.c in none/tests/x86
+       # -fstack-protector     more undefined references to __guard and __stack_smash_handler
+       #                       because valgrind doesn't link to glibc (bug #114347)
+       # -fstack-protector-all    Fails same way as -fstack-protector/-fstack-protector-strong.
+       #                          Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
+       # -fstack-protector-strong See -fstack-protector (bug #620402)
+       # -m64 -mx32                    for multilib-portage, bug #398825
+       # -ggdb3                segmentation fault on startup
+       filter-flags -fomit-frame-pointer
+       filter-flags -fstack-protector
+       filter-flags -fstack-protector-all
+       filter-flags -fstack-protector-strong
+       filter-flags -m64 -mx32
+       replace-flags -ggdb3 -ggdb2
+
+       if use amd64 || use ppc64; then
+               ! has_multilib_profile && myconf+=("--enable-only64bit")
+       fi
+
+       # Force bitness on darwin, bug #306467
+       use x86-macos && myconf+=("--enable-only32bit")
+       use x64-macos && myconf+=("--enable-only64bit")
+
+       # Don't use mpicc unless the user asked for it (bug #258832)
+       if ! use mpi; then
+               myconf+=("--without-mpicc")
+       fi
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       if [[ ${PV} == "9999" ]]; then
+               # Otherwise FAQ.txt won't exist:
+               emake -C docs FAQ.txt
+               mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
+       fi
+
+       dodoc FAQ.txt
+
+       pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # fix install_names on shared libraries, can't turn them into bundles,
+               # as dyld won't load them any more then, bug #306467
+               local l
+               for l in "${ED}"/usr/lib/valgrind/*.so ; do
+                       install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+               done
+       fi
+}
+
+pkg_postinst() {
+       elog "Valgrind will not work if glibc does not have debug symbols."
+       elog "To fix this you can add splitdebug to FEATURES in make.conf"
+       elog "and remerge glibc.  See:"
+       elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+       elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+       elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}