net-dns/avahi: Shift USE=gtk to mean GTK+3
authorMatt Turner <mattst88@gentoo.org>
Thu, 2 Apr 2020 18:26:27 +0000 (11:26 -0700)
committerMatt Turner <mattst88@gentoo.org>
Thu, 2 Apr 2020 19:02:06 +0000 (12:02 -0700)
Bug: https://bugs.gentoo.org/222601
Signed-off-by: Matt Turner <mattst88@gentoo.org>
net-dns/avahi/avahi-0.8-r2.ebuild [moved from net-dns/avahi/avahi-0.8-r1.ebuild with 95% similarity]
net-dns/avahi/metadata.xml

similarity index 95%
rename from net-dns/avahi/avahi-0.8-r1.ebuild
rename to net-dns/avahi/avahi-0.8-r2.ebuild
index 9002582868c269407935f0a88f0852f16bd0788f..aaf12d67acb3078e8c8b019d9b060365de1163f1 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/lathiat/avahi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="autoipd bookmarks +dbus doc gdbm gtk gtk3 howl-compat +introspection ipv6 kernel_linux mdnsresponder-compat mono nls python qt5 selinux systemd test"
+IUSE="autoipd bookmarks +dbus doc gdbm gtk gtk2 howl-compat +introspection ipv6 kernel_linux mdnsresponder-compat mono nls python qt5 selinux systemd test"
 
 REQUIRED_USE="
        python? ( dbus gdbm ${PYTHON_REQUIRED_USE} )
@@ -33,8 +33,8 @@ DEPEND="
        dev-libs/glib:2[${MULTILIB_USEDEP}]
        gdbm? ( sys-libs/gdbm:=[${MULTILIB_USEDEP}] )
        qt5? ( dev-qt/qtcore:5 )
-       gtk? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )
-       gtk3? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+       gtk2? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )
+       gtk ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
        dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
        kernel_linux? ( sys-libs/libcap )
        introspection? ( dev-libs/gobject-introspection:= )
@@ -131,8 +131,8 @@ multilib_src_configure() {
                --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
                $(use_enable dbus)
                $(use_enable gdbm)
-               $(use_enable gtk)
-               $(use_enable gtk3)
+               $(use_enable gtk2 gtk)
+               $(use_enable gtk  gtk3)
                $(use_enable howl-compat compat-howl)
                $(use_enable mdnsresponder-compat compat-libdns_sd)
                $(use_enable nls)
@@ -176,7 +176,7 @@ multilib_src_compile() {
 
 multilib_src_install() {
        emake install DESTDIR="${D}"
-       use bookmarks && use python && use dbus && use gtk || \
+       use bookmarks && use python && use dbus && use gtk2 || \
                rm -f "${ED}"/usr/bin/avahi-bookmarks
 
        # https://github.com/lathiat/avahi/issues/28
index eb8d32ab257f5fc9c5281c2e4d68c60c95bc4f55..0832dd78f28705fd48a77e86d03e2b12d016b8b3 100644 (file)
@@ -9,7 +9,10 @@
                <flag name="autoipd">Build and install the IPv4LL (RFC3927) network address configuration daemon</flag>
                <flag name="bookmarks">Install the avahi-bookmarks application (requires <pkg>dev-python/twisted</pkg>)</flag>
                <flag name="howl-compat">Enable compat libraries for howl</flag>
-               <flag name="gtk3">Build the avahi-ui-gtk3 library, and use gtk3 for the avahi utilities</flag>
+               <flag name="gtk"  restrict="&lt;net-dns/avahi-0.8-r2">Use gtk2 for the avahi utilities (overridden by USE=gtk3) and build the avahi-ui library</flag>
+               <flag name="gtk3" restrict="&lt;net-dns/avahi-0.8-r2">Use gtk3 for the avahi utilities (overrides USE=gtk) and build the avahi-ui-gtk3 library</flag>
+               <flag name="gtk2" restrict="&gt;=net-dns/avahi-0.8-r2">Use gtk2 for the avahi utilities (overridden by USE=gtk) and build the avahi-ui library</flag>
+               <flag name="gtk"  restrict="&gt;=net-dns/avahi-0.8-r2">Use gtk3 for the avahi utilities (overrides USE=gtk2) and build the avahi-ui-gtk3 library</flag>
                <flag name="mdnsresponder-compat">Enable compat libraries for mDNSResponder</flag>
        </use>
        <upstream>