games-simulation/corsix-th: tweak for gcc-10
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 13 Feb 2020 00:11:54 +0000 (00:11 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 13 Feb 2020 00:12:00 +0000 (00:12 +0000)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
games-simulation/corsix-th/corsix-th-0.62.ebuild
games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch [new file with mode: 0644]

index dd775153d21aa6f94206045f7b3c3e0085a02179..b7772ebb33819a9a2e253d447516af5f437d3445 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -34,6 +34,8 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/${MY_PN}-${MY_PV}"
 
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
 src_configure() {
        local mycmakeargs=(
                -DWITH_AUDIO="$(usex sound)"
diff --git a/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch b/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch
new file mode 100644 (file)
index 0000000..ff820f4
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/CorsixTH/Src/th_lua_map.cpp
++++ b/CorsixTH/Src/th_lua_map.cpp
+@@ -26,6 +26,7 @@ SOFTWARE.
+ #include <cstring>
+ #include <string>
+ #include <exception>
++#include <stdexcept> /* std::out_of_range */
+ static const int player_max = 4;