media-plugins/alsa-plugins: fix build with ffmpeg git master.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 14 Sep 2015 15:50:06 +0000 (17:50 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 14 Sep 2015 15:50:17 +0000 (17:50 +0200)
Package-Manager: portage-2.2.20.1

media-plugins/alsa-plugins/alsa-plugins-1.0.29-r1.ebuild
media-plugins/alsa-plugins/files/alsa-plugins-1.0.29-ffmpeg29.patch [new file with mode: 0644]

index 4e2b087585fa88d26fa3b84b23367111039986f6..667bf33122c9013122a45f9436794bc8addd2110 100644 (file)
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}
 src_prepare() {
        epatch "${FILESDIR}"/${PN}-1.0.23-automagic.patch
        epatch "${FILESDIR}"/${PN}-1.0.28-libav10.patch
+       has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}"/${PN}-1.0.29-ffmpeg29.patch
 
        epatch_user
 
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.29-ffmpeg29.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.29-ffmpeg29.patch
new file mode 100644 (file)
index 0000000..efd3783
--- /dev/null
@@ -0,0 +1,30 @@
+Index: alsa-plugins-1.0.29/a52/pcm_a52.c
+===================================================================
+--- alsa-plugins-1.0.29.orig/a52/pcm_a52.c
++++ alsa-plugins-1.0.29/a52/pcm_a52.c
+@@ -39,7 +39,6 @@
+ #endif
+ #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(53, 34, 0)
+-#include <libavutil/audioconvert.h>
+ #include <libavutil/mem.h>
+ #define USE_AVCODEC_FRAME
+ #endif
+@@ -513,7 +512,7 @@ static void a52_free(struct a52_ctx *rec
+               rec->inbuf = NULL;
+       }
+ #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
+-      avcodec_free_frame(&rec->frame);
++      av_frame_free(&rec->frame);
+ #else
+       av_freep(&rec->frame);
+ #endif
+@@ -557,7 +556,7 @@ static int alloc_input_buffer(snd_pcm_io
+ {
+       struct a52_ctx *rec = io->private_data;
+ #ifdef USE_AVCODEC_FRAME
+-      rec->frame = avcodec_alloc_frame();
++      rec->frame = av_frame_alloc();
+       if (!rec->frame)
+               return -ENOMEM;
+       if (av_samples_alloc(rec->frame->data, rec->frame->linesize,