www-client/otter: gnome2-utils => xdg-utils
authorJeroen Roovers <jer@gentoo.org>
Fri, 7 Jun 2019 20:53:27 +0000 (22:53 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 7 Jun 2019 20:53:43 +0000 (22:53 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
www-client/otter/otter-1.0.01.ebuild

index a2f202cc6df74ac3245d7595dfae877245580de3..4437dc69c96ef07206f66e728e826c29e77dadb5 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit cmake-utils desktop gnome2-utils xdg-utils
+inherit cmake-utils desktop xdg-utils
 
 DESCRIPTION="Project aiming to recreate classic Opera (12.x) UI using Qt5"
 HOMEPAGE="https://otter-browser.org/"
@@ -37,9 +37,8 @@ DEPEND="
 RDEPEND="
        ${DEPEND}
 "
-
-S=${WORKDIR}/${PN}-browser-${PV/_p/-dev}
 DOCS=( CHANGELOG CONTRIBUTING.md TODO )
+S=${WORKDIR}/${PN}-browser-${PV/_p/-dev}
 
 src_prepare() {
        cmake-utils_src_prepare
@@ -76,11 +75,11 @@ src_install() {
 }
 
 pkg_postinst() {
-       gnome2_icon_cache_update
        xdg_desktop_database_update
+       xdg_icon_cache_update
 }
 
 pkg_postrm() {
-       gnome2_icon_cache_update
        xdg_desktop_database_update
+       xdg_icon_cache_update
 }