x11-misc/gigolo: Replace gvfs-open with 'gio open' in defaults
authorMichał Górny <mgorny@gentoo.org>
Wed, 19 Jun 2019 12:11:35 +0000 (14:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 19 Jun 2019 12:11:35 +0000 (14:11 +0200)
Closes: https://bugs.gentoo.org/688022
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-misc/gigolo/gigolo-0.4.91-r1.ebuild [new file with mode: 0644]

diff --git a/x11-misc/gigolo/gigolo-0.4.91-r1.ebuild b/x11-misc/gigolo/gigolo-0.4.91-r1.ebuild
new file mode 100644 (file)
index 0000000..8a8013b
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="a frontend to easily manage connections to remote filesystems using GIO/GVfs"
+HOMEPAGE="https://www.uvena.de/gigolo/ https://goodies.xfce.org/projects/applications/gigolo"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+       >=x11-libs/gtk+-3.14:3"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig"
+
+src_prepare() {
+       rm COPYING || die
+       # https://git.xfce.org/apps/gigolo/commit/?id=fb63ddf0fa4ed93789366aefb7a2a2b44e919386
+       sed -i -e 's:gvfs-open:gio open:' src/settings.c || die
+       default
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}