Version bump, remove FUSE kernel module check as it now works with both the in-kernel...
authorPatrick McLean <chutzpah@gentoo.org>
Thu, 18 Jan 2007 14:29:44 +0000 (14:29 +0000)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 18 Jan 2007 14:29:44 +0000 (14:29 +0000)
Package-Manager: portage-2.1.2

sys-fs/ntfs3g/ChangeLog
sys-fs/ntfs3g/files/digest-ntfs3g-0.20070118 [new file with mode: 0644]
sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild [new file with mode: 0644]

index aad7a9eeca7822ad821a4da5329fa1f223db3d6c..64356f4fb9bad6929f96a861b5e40878c8a71a55 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-fs/ntfs3g
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.19 2007/01/16 03:14:24 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.20 2007/01/18 14:29:44 chutzpah Exp $
+
+*ntfs3g-0.20070118 (18 Jan 2007)
+
+  18 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
+  -ntfs3g-0.20061212.ebuild, +ntfs3g-0.20070118.ebuild:
+  Version bump, remove FUSE kernel module check as it now works with both the
+  in-kernel FUSE module and the FUSE package one. Clean out older version.
 
 *ntfs3g-0.20070116 (16 Jan 2007)
 
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070118 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070118
new file mode 100644 (file)
index 0000000..711c28c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f25c2a09926446168969bd093fda0079 ntfs-3g-0.20070118-BETA.tgz 562512
+RMD160 7765e159c3767bea82bcc8fc06262281d1b9d413 ntfs-3g-0.20070118-BETA.tgz 562512
+SHA256 7740d5fa1d9811263b06a11851e6359c4d62b65d0a4a2ba17497e94b8c1ab4c7 ntfs-3g-0.20070118-BETA.tgz 562512
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild
new file mode 100644 (file)
index 0000000..52c851b
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild,v 1.1 2007/01/18 14:29:44 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # default makefile calls ldconfig
+       sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "install failed"
+       dodoc AUTHORS ChangeLog CREDITS NEWS README
+}