dev-python/QtPy: Drop old
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 18 Jul 2019 20:28:56 +0000 (22:28 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 18 Jul 2019 20:58:03 +0000 (22:58 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/QtPy/Manifest
dev-python/QtPy/QtPy-1.3.1-r1.ebuild [deleted file]
dev-python/QtPy/QtPy-1.4.0-r1.ebuild [deleted file]

index d6bee717fe2bfffcd1b284351cee353fbf2a85f5..914a769263a6165c3eba8caf14559367b3b9bb1d 100644 (file)
@@ -1,3 +1 @@
-DIST QtPy-1.3.1.tar.gz 25061 BLAKE2B 5e504c9fd6182c23ec7f3160f6d2c073bb64bf3145b4336420be39dfda2d942633792abdcf2b7c0772ca7066e497d456667cbec2067a7798114929b0c9ca2d7d SHA512 3d06359b2793a57d8da715384b83e332cbc40d9f55699a2ddff0ebb04f527b9c629ea74b385103fd2ca98a79b02c8a582d16fa594048e7d56a32bda743da2008
-DIST QtPy-1.4.0.tar.gz 27019 BLAKE2B 6b90876f4801a19c98ddb8c4d678737a3b3ad61af1fe47c79b59b970ea4a895774bc554dfb9c99a4d806ad0316fb7c00e731c32a9d3f0a929a1f8bd4352851ab SHA512 7a989011114c17de29d5de6ff075935efdf9ebbae72d14580646bc81ce877f0beceaac511cade9e750dd9ee7e9f0f133c5676fa192ea906e7483feb543743379
 DIST QtPy-1.4.2.tar.gz 27471 BLAKE2B d70de67944a4019031b52cd3f6c588261537a74ce8b968d9577b016d18767e3e2b6981dae983573bd1644949b13ee271a10beaef9a371ac41b3cd1b9cb506cb2 SHA512 eb8a059f110f3262ab62f8198019b9826a5b834da62e59791fb3a6c235eb797291e4f180b31704d7d61811791e5b245a05b57fc385de358480561508e3b29a4d
diff --git a/dev-python/QtPy/QtPy-1.3.1-r1.ebuild b/dev-python/QtPy/QtPy-1.3.1-r1.ebuild
deleted file mode 100644 (file)
index 3468535..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstraction layer for PyQt5/PySide"
-HOMEPAGE="https://github.com/spyder-ide/qtpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="designer gui opengl svg testlib webkit"
-
-RDEPEND="
-       dev-python/PyQt5[${PYTHON_USEDEP},designer?,opengl?,svg?,webkit?]
-       gui? ( dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets] )
-       testlib? ( dev-python/PyQt5[${PYTHON_USEDEP},testlib] )
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-src_prepare() {
-       default
-
-       sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
-       sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
-       sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
-}
diff --git a/dev-python/QtPy/QtPy-1.4.0-r1.ebuild b/dev-python/QtPy/QtPy-1.4.0-r1.ebuild
deleted file mode 100644 (file)
index 3108385..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstraction layer for PyQt5/PySide"
-HOMEPAGE="https://github.com/spyder-ide/qtpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="designer gui opengl svg testlib webkit webengine"
-
-RDEPEND="
-       dev-python/PyQt5[${PYTHON_USEDEP},designer?,opengl?,svg?,webkit?,webengine?]
-       gui? ( dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets] )
-       testlib? ( dev-python/PyQt5[${PYTHON_USEDEP},testlib] )
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-src_prepare() {
-       default
-
-       sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
-       sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
-       sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
-}