dev-python/lxml: Revert "Enable py3.8"
authorMichał Górny <mgorny@gentoo.org>
Sat, 23 Nov 2019 15:26:11 +0000 (16:26 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 23 Nov 2019 15:38:17 +0000 (16:38 +0100)
It is more broken that it looked at a first glance.  Also, it was
supposed to say 'pypy3'.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lxml/lxml-4.4.1.ebuild

index a7f9ceeff70c9d423755e0d4d21f0cca217792d5..2d1ba408e65b77ff5e9da0bf18b02d88233b73a1 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
 
 inherit distutils-r1 eutils toolchain-funcs
 
@@ -24,7 +24,7 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 BDEPEND="
        virtual/pkgconfig
-       dev-python/cython[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*')
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
        "